Aeproject deploy isn't working with LIMA

Hey guys, maybe @aleksey.lime can help me.

I updated aeproject to the last version to compile and deploy my contracts.

I’m getting this error:

aeproject deploy -n testnet

API ERROR: Error: Unsupported node version 5.0.0-rc.4. Supported: >= 3.0.1 < 5.0.0

@ae-omar Hey, can you share which exact version of the aeproject are you using, because this should be fixed in 1.0.2. Today we will release new version also.

Best,
Martin

Also, in the project that you use the aeproject, did you make aeproject init --update to fetch the latest version ?

Best,
Martin

@MartinG I have 1.0.2

omarsaadoun$ aeproject -V

1.0.2

I did init --update with same result

Checking on docker files I can see that nodes config it’s ok but compiler is still with older version. I updated docker-compose.compiler.yml to :

version: '3'
services:
  compiler:
    hostname: compiler
    image: aeternity/aesophia_http:v4.0.0
    ports:
       - "3080:3080" 

And now it’s working well.

Note: ExampleContract.aes needs to be updated too.

Hi guys, the same here!

I had the same error message: Unsupported node version 5.0.0-rc.6. Supported: >= 3.0.1 < 5.0.0

After fetching the latest version with aeproject init --update, now I have the following error Compiler 3.2.0 support only consensus protocol less then 3(Fortuna).

@MartinG, @aleksey.lime can someone help?

Thanks! :slight_smile:

1 Like

WE have release 1.0.3 and there everything should be ok

@Sevgin_Mustafov Hey,

it seems that you have older version of aeproject, can you clarify that your version is 1.0.3?

you can check it like this aeproject -V

Best,
Martin

Hey @MartinG,

I had the following error message: "Unsupported node version 5.0.0-rc.6. Supported: >= 3.0.1 < 5.0.0"

Then I updated the aeproject to 1.0.3 and now I have the following error “Compiler 3.2.0 support only consensus protocol less then 3(Fortuna)” .

Best,
Sevgin

@Sevgin_Mustafov Hey, this issues is when using the aeproejct deploy? Can you check which compiler version you have? you can see that in the docker-compose.compiler.yml file and there is a row
image: aeternity/aesophia_http:v4.0.0 can you confirm that your version is 4.0.0?

ALso have you uninstalled forgae?

Best,
Martin

Hey @MartinG ,

Yes, I have uninstalled forgae. The compiler version is 4.0.0.

The contract deployment is fine, but when I run a server and request some of the endpoints it gives me: “Error: Compiler 3.2.0 support only consensus protocol less then 3(Fortuna)” Everything was fine 2 months ago when I initially created the project.

Best,
Sevgin

2 Likes

@Sevgin_Mustafov Can you give us more information on the scenario so we can reproduce it, which endpoints are not working well, how are you running your server etc. It seems to me that it is a bit a corner case, but we will investigate.

Thanks,
Martin

Hey @MartinG
Let’s say I have a function in the contract like this:

entrypoint get_balance(who : address) : int =

Chain.balance(who)

Then create:

async getBalanceOfAe(address) {

const balanceOfAe = await this.contractInstance.methods.get_balance(address);

return balanceOfAe.decodedResult

}

Note: I have initialized contract instance!

And my controller looks like the following one:

router.get(’/balanceof/:address’, errorHandler(async (req, res) => {

if(!req.params.address) {
  return res.sendStatus(400) 

}

const addr = req.params.address

const balance = await contract.getBalanceOfAe(addr)

res.json(balance)

}))

I run my server on port 3000 and with Postman I call the following endpoint, e.g.: localhost:3000/balanceof/ak_zPoY7cSHy2wBKFsdWJGXM7LnSjVt6cn1TWBDdRBUMC7Tur2NQ

And it gives me as I previously said: “Error: Compiler 3.2.0 support only consensus protocol less then 3(Fortuna)”

Best,
Sevgin

Hey Sevgin,

Hope you are well!

Do you happen to have this project uploaded anywhere online, so i can download locally and further investigate?
Also, feel free to DM me so we could export all the conversation elsewhere, (avoiding back and forth communication purposes)
I’d be happy to help

Enjoy the day!
Hristiyan

1 Like

In case you are not willing to dispose your project, following this topic please find below an old Forgae project which I managed to migrate to Aeproject.

I have build a simple API on port 3000 which deploys a contract, calls contract functions from both - the Aepp-SDK && Aeproject Deployer. Also managed to give some funds to the contract and display them as a response from the api.

I remain on your disposal if any further assistance is required.

Regards,
Hris

2 Likes

Hey @metselder,

I will check the project and test it, If there is still a problem I’ll DM you!

Thanks,
Sevgin

1 Like