Aeternity Windows Release (experimental) - Call for Testers

Just wanted to pop in and say hi. Been waiting for this windows version, going to see if i can get it to work on my 1060, 1070ti, 1080, and 1080ti rigs. It’s been a no go so far, but I’m going to keep at it and I’ll report back here/post any questions.

Update: So I am pretty sure I have this running smoothly on my 1080/1080ti rig with 5 cards. Just to double check, where is the best place to look for active mining happening? the epoch_mining.log (or epoch_pow) or elsewhere?

Good to hear. The log files epoch_pow_cuckoo.log and epoch_mining.log will show you what’s going on. Also in the task explorer you should see the binary cuda29 starting up frequently.

The next epoch release will come out later this week. I will then prepare another Windows release based on that one, which will include a few mining efficiency improvements.

I think it is funny you call it 1.0.1 but epoch says it is 1.1.0, can’t use aexplorer on this one without changing a few things.

Yes, because these releases were using changes from after v1.0.1, epoch itself reports to be v1.1.0, which wasn’t released at that time. I guess it makes more sense to stick to what epoch thinks while making experimental releases.

Epoch Windows Is it possible to mine in a mine pool?

that is not the objective of epoch as of now

Epoch as a wallet application only?

Epoch is a node, to serve as consensus, to distribute the network or solo mine.

Epoch may include a stratum-ready part so pools can use the epoch node.

Having said that, it seems outside of the scope of the epoch node to provide a gpu or cpu miner that connects directly to a pool. Unless the epoch includes a complete stratum pool (which doesn’t seem plausible, but it may happen) this is not something that will happen soon.

:slight_smile: You might be surprised :smiley: (will take time)

I’ve updated the original post with Version 1.1.0-experimental.1

I’m going to update everything today and see how it goes. If all goes good it will be running 24/7 from now on. On another note, is that bounty program still going for a mining guide? Couldn’t find it anywhere.

Edit: I found the guides, but it looks like they are all about running the node and mining with it. I was going to write a guide for mining with pools etc etc. Solo mining didn’t get much of a result in regards to blocks being found, which is pretty standard unless someone has a medium-big farm or gets lucky, getting a block on any algo through solo mining can take awhile.

1 Like

I followed the setup and got the node synced, then exited and set autostart to true for mining. Then it kept crashing whether or not I had autostart set to true or false. What is c:/Users/tino in there for? I had to delete the keys/ directory and now it seems to be working.


Error in process <0.367.0> on node epoch@localhost with exit value:
2018-12-27 14:48:40 =SUPERVISOR REPORT====
     Supervisor: {local,aecore_sup}
     Context:    start_error
     Reason:     {init_failed,[{aec_keys,enter_worker,3,[{file,"c:/Users/tino/Documents/work/epoch/_build/prod/lib/aecore/src/aec_keys.erl"},{line,349}]}]}
     Offender:   [{pid,undefined},{id,aec_keys},{mfargs,{aec_keys,start_link,[]}},{restart_type,permanent},{shutdown,5000},{child_type,worker}]

2018-12-27 14:48:40 =CRASH REPORT====
    initial call: application_master:init/4
    pid: <0.340.0>
    registered_name: []
    exception exit: {{{shutdown,{failed_to_start_child,aec_keys,{init_failed,[{aec_keys,enter_worker,3,[{file,"c:/Users/tino/Documents/work/epoch/_build/prod/lib/aecore/src/aec_keys.erl"},{line,349}]}]}}},{aecore_app,start,[normal,[]]}},[{application_master,init,4,[{file,"application_master.erl"},{line,134}]},{proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,247}]}]}
    ancestors: [<0.339.0>]
    message_queue_len: 1
    messages: [{'EXIT',<0.341.0>,normal}]
    links: [<0.339.0>,<0.33.0>]
    dictionary: []
    trap_exit: true
    status: running
    heap_size: 987
    stack_size: 27
    reductions: 193

The duty cycle on the GPUs is not consistent, is that what others are seeing?

@ExtremeT were you able to connect to a pool?

Hey Argyle,

The c:/users/tino part I’m not sure of. It seems like it didn’t load up the key properly and so threw the errors, which is probably why when you deleted it and it (more than likely) remade it, that it runs fine now, but I could be wrong about that since I didn’t have that problem myself. I’m sure someone more versed in that area will be able to answer better.

For the rest, yea that is how it looks like in afterburner since every time it starts a new ‘puzzle’ to solve it starts up a new instance, hence why you see the graph jumping like that. It’s totally normal.

With Epoch you can’t connect to pools right now through it as there’s no support for Stratum. I think it is being worked on, from what I’ve read in response to similar questions. Currently Epoch is for running a consensus node and solo mining. If you want to connect to a pool, there are only 3 available, all of which are in Chinese, and require the use of MinerOS and the pool’s specific mining software, most of which is also in Chinese.

I’m currently writing a Guide on how to do that, as well as working on a way that I can host a pool in English and an easier way for people to connect to it because right now it is a pain to do unless you know Chinese. I know of a couple of other places working on a possible pool, but right now there’s nothing solid and working besides the above mentioned ones.


The path is irrelevant.

The crash log itself doesn’t indicate what went wrong with the keys. You should have some other error logs at the same time in the epoch.log which would help find the root cause.

As @ExtremeT already described the up-and-down GPU utilization is due to the nature of how epoch uses the external miners at the moment.

@ExtremeT Stratum support is work-in-progress. If you need a hand or mind in regards to the pool, feel free to ping me via PM.

yea I was just guessing about the keys part lol I figured Stratum was in the works which is great. As for the pool, I’ll hit ya up in pm =)

What is the windows node status?

Hey @doge

The Windows node is still experimental but it should work properly, have you tried it?

Hi @doge! Here you can fine the latest version of the Windows node.

1 Like

Excellent. Makes development much easier!

1 Like

This topic is somewhat closed now. New release can always be fetched from Github.