Can't get node pub_key


#1

Hey all, I have set up epoch node on docker. When try to get pub_key - curl http://127.0.0.1:3113/v2/account/pub_key --verbose
result is:

curl: (7) Failed to connect to 127.0.0.1 port 3114: Connection refused

node is up and running, because …/top return same height as other nodes.

Any ideas what might be wrong?


#2

Hey @lcsavov,

Our dev team has been informed about your problem,
so they’ll get back to you as soon as possible.

Regards,
The AE Team


#3

Hey @aeternity-team, when node is running locally it works. Maybe it is something related to docker setup.


#4

@lcsavov if you followed the documentation at https://github.com/aeternity/epoch/blob/master/docs/docker.md#start-a-node

The example does not expose the (default) internal port (3113). You shall use additional docker parameter -p 3113:3113 to do that.

docker run -d -p 3013:3013 -p 3113:3113 \
    -v ~/.aeternity/myepoch.yaml:/home/epoch/myepoch.yaml \
    -e EPOCH_CONFIG=/home/epoch/myepoch.yaml \
    aeternity/epoch -aehttp enable_debug_endpoints true

Please refer to docker documentation for additional details: https://docs.docker.com/config/containers/container-networking/

BTW, your command and it’s output in the OP is somehow broken. You requested port 3113 while the error output relates to port 3114.


#5

Thank you for the answer!