Epoch Windows Release (experimental) - Call for Testers


#123

No, I picked it from a MacOS test run, but I’d expect it to be similar on Widndows


#124

It seems, that log are different in ubuntu and windows…Anyway i not seeing mesages about block finding in mining.log.


#125

if you are mining on mainnet it will be a while for you to see a block.


#126

Ok, this may be a stretch, but how can i start several epoch’s on the same computer?

I tried going to the vm.args file to change the erlang name to [email protected], but when i do that the epoch node will not start and ports won’t open. I don’t see any other reference to [email protected] anywhere in the code though.

What am i missing?


Edit: answering my own question. you need to set it to “epoch1” without host. and it will run properly.

Yay! I can set up an easy demo network with this thing now.


#127

changed network id and mining for hours, can’t find mined block in log file…what to do know?
i have 6 x gtx1070 cards.

    # CUDA mining configuration
     miner:
         executable: cuda29
         extra_args: "-d 5"
         edge_bits: 29
         hex_encoded_header: true
         # Number of GPU devices which should be used in parallel.
         instances: 5

#128

On 8Gb cards cuda miner gets out of memory error in stock (not always). You need -E 1 extra arg. But my OS hangs up in this case. I Returned to ubuntu and it works more better (solutions goes more rapidly). I think, guys with 1080Ti has no this bug.


#129

yes, use -E 1 working on test network, but same as you, OS hang up when mining on mainnet…

win10 64bit, 4gb ram. g3900 cpu.


#130

Win 10 64, 8Gb, G4400
Ubuntu is the only way, while they recompile cuda29.
Can you try -E 2 param?


#131

not working. i have 6 cards, if use 3-5 cards, it only can running for minutes and crashed…or OS hang up…


#132

Don’t combine extra_args: "-d 5" with instances: 5 - the latter will automatically add -d 0, -d 1, …, -d 4 respectively to the miner-commands being run…


#133

Which 8GB card are you using when this error comes up? Also is the card also being used by your OS?


#134

@aeminer @zimkan The -E parameter doesn’t apply to the CPU miners, it is only used by the CUDA miner. Thus, the memory allocation of the CPU mining process (3.x GB) might for some reason crash your system. Before such a crash the node should have written some logs. Could you post these somewhere?


#135

there is only cuda29 in my epoch.yaml


#136

I am looking forward for a version that includes the new Cuda miner and epoch with support for better context usage


#137

And I am too wait. Please do it asap.