Error using testnet.contracts.aepps.com

Since the lima update the testnet returns this error on loading the page,

Error connecting to https://sdk-testnet.aepps.com/ – Modify Settings

Error: Unsupported node version 5.0.0-rc.4. Supported: >= 3.0.1 < 5.0.0 (wrong private/public key)

any fix available?
@Steviekusu

Error below:

1 Like

@erik93 @ae-vlad @ae-albena please can you directed this to the appropriate person to help respond to this?