Frequently Asked Questions (FAQ): Token Migration Phases 1, 2, 3


I think I looked at your information, and it shows the correct information here:

I used the information from your etherscan link page (the block holding “original” data at the bottom of that page (select the “view as original input” option) into the verify page payload input box. It shows what appears to be the same address.


I looked at your data on:
… and it appears correct too. I think it’s the AE tool that is not calculating the data correctly for the display.


I checked constantly the migration result page, till now seems the last 2 migrations successfully went through and showed on the page and in my wallet, but the first 2 still missing…

Until we make clear what happend, I can’t risk to migrate large amount of tokens!

If you need anything from me to check, like my ETH adress or TxID, please tell me. Awaits your feedback. thank you!


I do not have any screenshots. but the problem can be replicated easily if the devs can make a new AE address and migrate to that address more than one time. If they can not replicate the issue, then there is another more serious problem.


Hello i have yet another problem with the migration contract!

my transaction:

821.94 tokens
when i check my payload all is ok:

but when i check my migration, there is nothing:

This is the second transaction in a few days that have gone missing GRRRRR

Surly something is going wrong with migration process & needs to be addressed urgently!
please help me!


Hey @martin61

We are currently investigating but we think that there most probably is a problem with the tool that displays the successful migration.
Which means that your tokens should be fine, we will confirm in a bit.



Thank you Albena…


I created my account with aecli and manually entered the address into the migration website. I migrated 100 AE from MetaMask to my newly created address. I got a success message but the verify tool shows 0.0 AE migrated. It looks fine on Etherscan -

Why does it show 0.0 on the verify tool? The address I used is ak_L3pUDjN9BLBNHSkvFvDRrSqSqzQiTYiNp4XDroZupr5d7HSKE



Hey @cpca232, sorry for that. We put fixes in place and you should be able to see everything correctly now, could you please check?

It is just a displaying issue, your tokens were never lost in any form whatsoever :wink:

Highly apologize for any inconvenience, we really appreciate your help in reporting bugs and issues so we can improve things constantly, you guys are being a really big help to us.


Update it’s working now. Maybe it just takes a while to change from 0.0 to the full amount.

------ previous message -------
Thanks! I see them now. I also migrated a second batch which worked perfectly. But now I am having the exact same problem with a third batch. Can you check this one?

My address (created with aecli) is -


It shows 0.0 AE migrated :frowning:


My migration is displaying correctly now, phew! Good job team you fixed it with plenty of time to spare before the fork!


Hey @cpca232, @drugzbymail, thanks for your guys’ feedback! I just checked everything again, it seems like it’s all there as supposed to be. Please excuse any delays, I am trying to figure out what the reason for this is. It’s certainly rooted somewhere in the fact that we are constantly (re-)scanning the Ethereum network for these token burnings. There is one important thing I would like to state:

All migrated tokens will always be delivered in the hard forks, no matter what. Even if all our servers and laptops explode the same time. That is because we do not trust some database which we have to use in order to display the migrations to you, but do a fresh rescan of all migrations right from the Ethereum network with the same tool which we made public for the sake of verification of the amounts of AE delivered in the hf.

So, rest assured that you can safely migrate all your tokens anytime.


Problem with AirGap Vault

Hi guys, I’d like to migrate my AE ERC-20 tokens and try some mining with a AE Roma wallet/address.
To achiev that I installed AirGapVault on my Android 7.1.1 Smartphone.
Unfortunately AGV hangs in the security setup.
After entering the fingerprint or the security code at the end of the setup to confirm the setup the app closes.
I never arrive at the wallet selection screen.
It just starts again with the security setup, altough I can’t see any mistake on my side.
The app has the necessary rights.
Its really annoying.
Any suggestions or help? Already lost more than 2h in the setup process.


Hey @Stefan_K,

We’ve forwarded your problem to the Airgap team and they’ll get back to you :wink:



Thanks @ae-albena I’m already in contact with them.


The migration of my AE ERC-20 token was successful, today.
I will write a separate topic about my experience.


Any news about Binance migrating?


+1, this should be high priority in my opinion to reach Binance and have them support AE migration. Would as well help faster adoption to the new Token/Coin. Same goes for some other of the top AE volume exchanges in my opinion…


Hey @boxalex and @Drugzbymail

We can’t really talk on behalf of the exchanges and we cannot commit to e specific date when the large exchanges would support the mainnet AE token.

For now, we are listing all the exchanges that support the token and the migration in that spread sheet.

We’ll keep you updated as soon as we have more info.



Hey everyone,

The end date of Phase 1 of AE Token Migration is now available - February 15th, 2019! :wink:

All AE tokens migrated prior to February 15, 2019 | 11:59:59 PM CET will become available on æternity’s Mainnet after the scheduled February fork.

Who hasn’t migrated yet?