Got this error when running "forgae node"

C:\Users\goote_000\Documents\smart_contracts\new_aepps\voting_app>forgae node
error: 'Error: Command failed:

docker ps

error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.39/containers
/json: open //./pipe/docker_engine: The system cannot find the file specified. I
n the default daemon configuration on Windows, the docker client must be run ele
vated to connect. This error may also indicate that the docker daemon is not run
ning.
’ stdout = ‘’ stderr = 'error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker
_engine/v1.39/containers/json: open //./pipe/docker_engine: The system cannot fi
nd the file specified. In the default daemon configuration on Windows, the docke
r client must be run elevated to connect. This error may also indicate that the
docker daemon is not running.

meanwhile when i run “docker ps” i get this
C:\Users\goote_000\Documents\smart_contracts\new_aepps\voting_app>docker ps
CONTAINER ID IMAGE COMMAND CREATED
STATUS PORTS NAMES

docker-machine version 0.16.1, build cce350d7
Docker version 18.09.3, build 774a1f4eee

1 Like

@Goodness have you installed the docker desktop version on your machine? You need to have it and to run the docker deamon

i have docker toolbox

Forgae doesn’t work with docker toolbox, you need to install the full version. Docker toolbox is deprecated and uses old versions.

1 Like

wow!!!
there is no docker desktop version for windows 8.1
so what do i do???
is there another alternative??
must i use forgae??

1 Like

Hey, we need to check and try to workaround it, as far as I know there were some limitations for the docker toolbox.

is there a way to write my contract locally without using forgae???

i read something about aeophia
how i install that
its not on the docs

Have you tried the https://testnet.contracts.aepps.com ? Here you can develop, compile, deploy and interact with the smart contracts. It is connected to the sdk-testnet and to the latest compiler version which is 3.2

1 Like

thats was what i was trying to avoid:sweat_smile::sweat_smile:
thats y i installed forgae in the first place
https://testnet.contracts.aepps.com requires me to be online
bt since i don’t have an option i’ll just build my contracts there

the workaround is running the nodes “manually” by executing docker-compose up with docker-toolbox.

@MartinG haven’t checked -> but is it possible to configure the URL(s) that forgAE is pointing to? that would be a requirement to be able to use docker-toolbox

1 Like

@marc0olo thanks for the help. What do you mean by the URLs ? We have to check what are the limitations of the docker toolbox so we can skip them in forgae

on docker-toolbox it is not possible to access the containers through localhost. so you need to visit http://192.168.x.x to access them.

so it would be necessary for docker-toolbox-users to configure the baseUrl in order to make forgAE work with running.

best scenario would be that forgAE detects the error when trying to run forgae node and gives the user a hint:

  • “if you are using docker-toolbox then please start the nodes by running docker-compose up and configure the forgAE baseUrl manually with the following command …”

edit:

  • in the past “localhost” was hardcoded in forgAE, so it wasn’t possible to configure the baseUrl
  • don’t know about the current state
2 Likes

@marc0olo Great explanation, thanks! We will create an issue about this and will implement it.

Thanks,
Martin

Great conversation to see how many “edge cases” there are that are popping up. Thanks for giving support here both of you!

1 Like

where have u been :tired_face:
i’ve been on this for like 3 days now :sweat_smile:
let me try this

[email protected] MINGW64 ~/Documents/smart_contracts/voting_app
$ forgae compile
===== Compiling contracts =====
API ERROR: Error: connect ECONNREFUSED 127.0.0.1:3001

have u gotten a way on how to configure the baseUrl???

in the past I modified forgAE by myself to get this working by replacing the hardcoded baseUrl with the one I needed. but then you also need to build forgAE on your machine and configure NPM to use your local built version.

otherwise you probably need to wait until the baseUrl can be configured, sorry! I know this can be frustrating, but I am sure this problem will get solved :slight_smile:

1 Like

thats a serious setback, hope the aeternity team will work on that and come up with a solution as fast as possible

1 Like

I’m sure its in progress. I’ll check with @MartinG.