[GPU Mining] Setup Collaboration Thread {DEVS TOO}


#1

Hi,

since docs aren’t watertight for the setup of cuda29 mining I want to open this thread so we can help one another. I had a nicely working 0.21 epoch node setup that worked perfectly. I wanted to upgrade to a newer node before mainnet and now I run into issues.


#2

1st question: does v0.25.0 have cuda29 support ? I get the rather clear error message
make: *** No rule to make target 'cuda29'. Stop.
when executing
cd apps/aecuckoo && make cuda29.
Checked the makefiles. No cuda29 in there at all. So maybe no support on this branch ? But then …
Attempted solution 1: checkout different branch
Unfortunately, for some UNKNOWN reason, I cannot checkout branch v1.0.0-rc2 …
git checkout tags/v${VERSION:?}
error: pathspec 'tags/v1.0.0-rc2' did not match any file(s) known to git.
Attempted solution 2
git fetch --all --tags
No effect. Same behaviour as above.

How can I get to compile the cuda29 miner ?


#3

2nd question: how many days are planned between final RC release and launch ?


#4

Hey @doge,

Our developers will get back to you ASAP.

Regards,
Albena


#5

Hey @doge,

Find the cuda instructions for 0.25 here.

Version 0.25 is using the old naming scheme, i.e. it should be cuda30 there.

Let us know if you have any other questions.

Regards,
Albena