Node error with no feedback


#1

I installed the node and the right libsodium for ubuntu 16.04

I installed everything in the home directory of a new user named aeternity, with all the rights to this user

Unfortunaly, when I type “./epoch start” in the bin/ directory, it exits with no feedback, no error message, nothing in the log directory and no dump file.

What’s the problem here ? Can’t the epoch program gives at least a feedback ?


#2

Hey @lofino,

Thank you for your question.

Our dev team will get back to you as soon as possible.

Regards,
The AE Team


#3

Thank you. I tried the docker way as well, but same results. The instance exists instantly and no feedback.


#4

Tried the compiling way as well. Same result, “./bin/epoch start” doesn’t start the daemon and exits with no error message. Tried to check this shell script out, but it’s kinda long.

My epoch.yaml file is parsed successfully btw.


#5

I’ve never seen the epoch node to not write any logs, are sure that’s the case?
Try deleting all the files in log directory and start it again, if that still not produce any logs try to run the node with strace e.g. strace -f bin/epoch start and posting the output to a gist.github.com (or alternative service).


#6

Deleting files is something I tried already. Even allowing the 777 rights to the entire directory, just in case :sweat_smile:

This is the strace output : https://gist.githubusercontent.com/entinio/c6322d02074131fa35e1ccd14a342c05/raw/c3f8b52b6f5c2a7d362af2c041c807ce00b10bf9/strace.log


#7

I might be wrong but I think I’ve seen this issue already. In the strace output I see:
mknod("/tmp/erl_pipes/[email protected]/erlang.pipe.1.r", S_IFIFO|0600) = -1 EACCES (Permission denied)

This could happen if you tried to run a node as root user before. Please check the permissions and ownership of /tmp/erl_pipes/ and it’s subdirectories.

Even easier, try deleting the directory (sudo rm -rf /tmp/erl_pipes/ and then start the node.

Please let me know if that makes any difference.


#8

Here I am, testing again :wink:

Ok, this “rm” command allowed me to get log files now (you should provide a console output for this case).

Unfortunately, I now get another type of crash :sweat_smile:

2018-10-16 23:13:34 =ERROR REPORT====
aecore_app:check_env()-> ERROR: {badmatch,{error,eacces}}
[]
2018-10-16 23:13:34 =ERROR REPORT====
Abort on error is set. Terminating sequence

something else is left from my first launch as a privilege user ?


#9

Most probably, try installing in a separate directory (new install) with non-privileged user.


#10

Yep. Was better initiating the install from a non-privileged user from the start. This should be a big warning at the top of the tutorial, especially since using a privileged user led me to the previous behavior.

Anyway, thank you for your help!