Online compiler sometimes giving error

https://contracts.aepps.com
Test contracts Error connecting to https://testnet.aeternity.io/ – Modify Settings
Error: Network Error (wrong private/public key)

(the error comes and goes, sometimes it works fine)

Hey thanks for the issue reported. Unfortunately the contracts aepp will be discontinued soon. We will check the error though.

In the meantime I will suggest to you to use the fire editor - http://fireeditor.nikitafuchs.de/

It is the most up-to-date online editor for now.

Best,
Martin

1 Like

Should be working more stable now, please try to clear your browser cache.

1 Like

Thanks! Btw do you know why will the contracts aepp be discontinued?

The new editor is superior in terms of functionality. It makes no sense to support a subset of it’s functionality in a separate project.

As it’s open source already the community can keep it going anyway, new maintainers are very welcome

3 Likes

@DinchoTodorov.chain has the online compiler CORS issue been resolved?
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://latest.compiler.aepps.com/decode-call-result. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing)

Hey @CryptoTask, please see below:

Can we mark this issue as solved?

Still getting the same error

1 Like