Questions building a State Channel App with the JS SDK


#1

Hi,

i’m trying to build a simple aepp. I followed the step-by-step guide here https://dev.aepps.com/tutorials/account-creation-in-ae-cli.html to first create an aeternity key-pair and run into this error message:

async function promptPasswordAsync ()

SyntaxError: Unexpected token function

What are my next moves?


#2

The nodejs version is too low?

How about upgrade nodejs to the latest version to support async?


#3

I was running nodejs v6.16.0

Thank you @Liu ! Now it seems to work.


#4

Is someone around who can help me with running a node on an amazon aws ec2? I think i finally managed to raise ulimit but i think i can not start the node in a way that it is reachable from public (i’ve tried ./bin/aeternity start and then i tried to query the top with the ip of my server but that times out so i guess its not running curl http://18.222.106.194:3013/v2/blocks/top ) - do i have to open the 3013 port somewhere on Amazon to make it possible to query it?


#5

Start the node with ./bin/aeternity console, which could show running status and problems in the node.

Ubuntu 18.04 seems to be the most convenient OS for node.