(SOLVED) API ERROR when deploying contract (unsupported node version)

Hello, I’m new to the aeternity documentation and I’ve been following along with the examples. I’ve manually created a wallet and now I’m trying to deploy a contract by following the step by step instructions from http://aeternity.com/documentation-hub/tutorials/smart-contract-deployment-in-forgae/

But when I run the deploy command:

forgae deploy -n mainnet -s <my-private-key>

it gives me this error:

API ERROR: Error: Unsupported node version 5.0.1. Supported: >= 3.0.1 < 5.0.0

I guess I just have to rollback my node version, but I haven’t gotten this error before and if anyone has
a fast and neat way of fixing this I’ll be forever grateful.

1 Like

i think its because u are still using forgae
try aeproject
Documentation https://aeproject.gitbook.io/aeproject/


Yes, this is correct. It was a bit confusing that it was renamed. We should point this out in the documentation hub too @pegah :slight_smile:


Aeproject works nicely, thank you very much!

And yes, it did cause some confusion on following the docs :sweat_smile:

1 Like

Thanks! Cleared it up for me

1 Like