(solved) Connect ECONNREFUSED when testing SDK

Hey guys,

So I have a working sophia smart contract that I can compile through the CLI without a problem,
then I tried using the SDK, following this guide - https://github.com/aeternity/aepp-sdk-js/blob/develop/docs/examples/node/aecontract.md

But when I try to run the file, it gives me


ps: The node is started with, sudo dockerd in the project folder, then sudo aeproject node

Help would be greatly appreciated :pray:

First it would be good if you set up your docker to work without sudo as this is not what aeproject is supposed to work with internally, maybe the issue is because of this.

Otherwise did the aeproject node call finish successfully showing funded wallets?
What does curl localhost:3013/v2/status show?
Do the docker logs docker-compose logs -f indicate any errors?

1 Like

Hi, thanks for the response

1.Yes, sudo aeproject node finishes successfully.
2. curl localhost:3013/v2/status
gives me:
curl: (7) Failed to connect to localhost port 3013: Connection refused
3. docker logs (without sudo) show:
ERROR: Couldn't connect to Docker daemon at http+docker://localhost - is it running? If it's at a non-standard location, specify the URL with the DOCKER_HOST environment variable.


sudo docker-compose logs -f gives no errors

1 Like

Okay, sorry about that, I just noticed the mistake, aeproject node spawns nodes under different ports, so 3001 instead of 3013 should work.

1 Like

Yup, compiles without errors, thank you!

1 Like