Start epoch and console print....and log directory is empty


#1

018-12-13 11:50:07 crash_report
initial_call: {supervisor,kernel,[‘Argument__1’]}
pid: <0.987.0>
registered_name: []
error_info: {exit,{on_load_function_failed,rocksdb},[{init,run_on_load_handlers,0,[]},{kernel,init,1,[{file,“kernel.erl”},{line,217}]},{supervisor,init,1,[{file,“supervisor.erl”},{line,294}]},{gen_server,init_it,2,[{file,“gen_server.erl”},{line,365}]},{gen_server,init_it,6,[{file,“gen_server.erl”},{line,333}]},{proc_lib,init_p_do_apply,3,[{file,“proc_lib.erl”},{line,247}]}]}
ancestors: [kernel_sup,<0.961.0>]
message_queue_len: 0
messages: []
links: [<0.962.0>]
dictionary: []
trap_exit: true
status: running
heap_size: 610
stack_size: 27
reductions: 235
2018-12-13 11:50:07 supervisor_report
supervisor: {local,kernel_sup}
errorContext: start_error
reason: {on_load_function_failed,rocksdb}
offender: [{pid,undefined},{id,kernel_safe_sup},{mfargs,{supervisor,start_link,[{local,kernel_safe_sup},kernel,safe]}},{restart_type,permanent},{shutdown,infinity},{child_type,supervisor}]
2018-12-13 11:50:08 crash_report
initial_call: {application_master,init,[‘Argument__1’,‘Argument__2’,‘Argument__3’,‘Argument__4’]}
pid: <0.960.0>
registered_name: []
error_info: {exit,{{shutdown,{failed_to_start_child,kernel_safe_sup,{on_load_function_failed,rocksdb}}},{kernel,start,[normal,[]]}},[{application_master,init,4,[{file,“application_master.erl”},{line,134}]},{proc_lib,init_p_do_apply,3,[{file,“proc_lib.erl”},{line,247}]}]}
ancestors: [<0.959.0>]
message_queue_len: 1
messages: [{‘EXIT’,<0.961.0>,normal}]
links: [<0.959.0>,<0.958.0>]
dictionary: []
trap_exit: true
status: running
heap_size: 376
stack_size: 27
reductions: 213
2018-12-13 11:50:08 std_info
application: kernel
exited: {{shutdown,{failed_to_start_child,kernel_safe_sup,{on_load_function_failed,rocksdb}}},{kernel,start,[normal,[]]}}
type: permanent
{“Kernel pid terminated”,application_controller,"{application_start_failure,kernel,{{shutdown,{failed_to_start_child,kernel_safe_sup,{on_load_function_failed,rocksdb}}},{kernel,start,[normal,[]]}}}"}


#2

The database backend didn’t get loaded. What binary you are running? Did you compile it on your own? On what platform?


#3

Hi,
What I compiled is Roma maintenance release.
I run it on CentOS


#4

When I run with root user, I report “bit set is not allowed to run without setting effective user!” and then I change to admin user to compile epoch, and then it reports the error.


#5

Can you inspect compilation print out? Did rocks db dependency downloaded and compiled correctly?

Maybe you touched something as root and your current user has no right to it now?

Can you start from scratch and compile as final user?


#6

Hi,I didn’t find a special exception log, or did CentOS make any difference?
CC utilities/blob_db/blob_dump_tool.o
AR librocksdb.a
ar: creating librocksdb.a
make[3]: Leaving directory /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/deps/rocksdb' make[2]: Leaving directory/home/admin/luguiqi/epoch/_build/default/lib/rocksdb/deps’
cc /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/erocksdb_snapshot.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/erocksdb_db.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/transactions.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/erocksdb_iter.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/backup.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/erocksdb.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/erocksdb_column_family.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/env.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/util.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/rate_limiter.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/refobjects.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/counter_merge_operator.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/batch.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/bitset_merge_operator.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/erlang_merge.o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src/cache.o -L /usr/local/lib/erlang/lib/erl_interface-3.10/lib -lerl_interface -lei -lstdc++ /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/deps/rocksdb/librocksdb.a /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/deps/snappy/.libs/libsnappy.a /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/deps/lz4/lib/liblz4.a -shared -lpthread -lrt -lgflags -lz -lbz2 -lzstd -o /home/admin/luguiqi/epoch/_build/default/lib/rocksdb/priv/rocksdb.so
make[1]: Leaving directory `/home/admin/luguiqi/epoch/_build/default/lib/rocksdb/c_src’
===> Compiling mnesia_rocksdb


#7

I compiled it according to this:


Did I miss anything?

chain:
    persist: true
    db_path: ./my_db

Do I need to create the db_path directory?


#8

by default no, if u use this it is ok, if u are on linux and if you are on home directory otherwise you need sudo to create and set the right rights.

If your user id is 1000 it will run as documented all other cases are untested I think.

Some recommended packages need sudo, but not epoch.

I run into many problem as I tried to install it on /opt folder, so I followed the docs and installed epoch on home directory


#9

Is there anything wrong with my configuration file?

ync:
port: 3015

keys:
dir: keys
peer_password: okkey

http:
external:
port: 3013
internal:
port: 3113

websocket:
channel:
port: 3014

mining:
beneficiary: ak_26BCaru3v2CvLt94aWn9UpwmGAgthHYZ7VmFmSpagGcCBiLmFV
autostart: false

chain:
persist: true
db_path: ./chain

fork_management:
network_id: ae_mainnet


#10

my userid is 1000
admin:x:1000:1000::/home/admin:/bin/bash