Problem installing Forgae/AEproject

@martingrigorov.chain can probably help you :slight_smile:


Hey @rwfresh here is an old forum post that solves the problem,

You can try installing this as an administrator:

I have tested this yesterday with the same configuration as yours and it worked.


1 Like

I had a similar error under macOS which I solved by running it this way:

sudo npm install -g aeproject --unsafe-perm=true --allow-root


I have tried this multiple times and it still gives me same error can i please get some one who i could talk to directly anytime or chat with privately to help me out



Make sure that you have already launched a Linux instance with a public DNS name that is reachable from the Internet and to which you are able to connect using SSH

Hi Martin, thanks for the info. windows-build-tools Already installed without issue. Also have Visual Studio 2017 installed. Just tried again with admin rights cmd shell. Same error.

@Enokela Is your error the same as the one that @rwfresh has reported? What OS you are using, node version, and python?


@rwfresh Have you checked the article I have posted? I will try to reproduce the issue. The issue is actually with the argon library which is a dependency in aeproject, from another library… Maybe you can try with python version 2.7, it worked from some community members.


Using python 2.7.16 and node.js 10.16.3 windows 10 OS

Windows 10 Pro or Home, this also makes the difference?

windows 10 Enterprise, i would add some screen shots and the log it developed when i tried the “npm i -g forgae” command

C:\Windows\System32>npm i -g forgae
C:\Users\SMOKE\AppData\Roaming\npm\forgae -> C:\Users\SMOKE\AppData\Roaming\npm\node_modules\forgae\forgae-cli.js

[email protected] install C:\Users\SMOKE\AppData\Roaming\npm\node_modules\forgae\node_modules\argon2

C:\Users\SMOKE\AppData\Roaming\npm\node_modules\forgae\node_modules\argon2>if not defined npm_config_node_gyp (node “C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )
Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
Building the projects in this solution one at a time. To enable parallel build, please add the “/m” switch.
MSBUILD : error MSB3428: Could not load the Visual C++ component “VCBuild.exe”. To fix this, 1) install the .NET Framew
ork 2.0 SDK, 2) install Microsoft Visual Studio 2005 or 3) add the location of the component to the system path if it i
s installed elsewhere. [C:\Users\SMOKE\AppData\Roaming\npm\node_modules\forgae\node_modules\argon2\build\binding.sln]
gyp ERR! build error
gyp ERR! stack Error: C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe failed with exit code: 1
gyp ERR! stack at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\build.js:262:23)
gyp ERR! stack at ChildProcess.emit (events.js:198:13)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
gyp ERR! System Windows_NT 10.0.17763
gyp ERR! command “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\Users\SMOKE\AppData\Roaming\npm\node_modules\forgae\node_modules\argon2
gyp ERR! node -v v10.16.3
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm ERR! errno 1
npm ERR! [email protected] install: node-gyp-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\SMOKE\AppData\Roaming\npm-cache_logs\2019-10-14T11_14_51_815Z-debug.log


Hi, @Enokela.
I just test on my system. win 10 pro, node v11.12.0, Python 2.7.14.
edit path in system environment variables -> path -> edit and change “C:\Windows\Microsoft.NET\Framework\v2.0.50727” to “C:\Windows\Microsoft.NET\Framework\v4.0.30319”.

then type in ‘command prompt’ :
“SET VCTargetsPath=C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140”
and you should be able to install aeproject globally.

1 Like

i saw Docker on your environment do i install that too?

yes, you should install docker too or you wont be able to start the ‘node’

just uninstall current docker and install it again from (14.10.2019)
PS: do not click on checkbox for “windows images” or something like this
then everything should be work

Note: VirtualBox will no longer work.

@Enokela docker is needed for running the node and the compiler once you install the aeproject, but it shouldn’t be a problem for just installing it.


Hi Martin, yes I did check this as soon as you posted it. The solution for the person that was having the same issue was to install VS 2017 which I already have installed. I also have VS 2019 installed. Could be some conflict? Not sure what. I will try downgrading to python 2.7 from 3.7 as was also mentioned. I will report back here. Thanks for all your help!

1 Like

Downgrading to python 2.7(16) worked! Thanks @martingrigorov.chain, looking forward to getting something going!