Problem installing Forgae/AEproject

Downgrading to python 2.7(16) worked! Thanks @MartinG, looking forward to getting something going!

rw

2 Likes

@MartinG i took care of the first error for the VC by doing this npm install --global --production [email protected] (i added the @4.0.0) and this helped install the build tools even though it took a long time so it could be helpful if in case anyone goes through the same issues. I have a new error though, i ran the npm i -g forgae and it returned this error bellow

C:\Users\SMOKE\AppData\Roaming\npm\node_modules\forgae\node_modules\argon2>if not defined npm_config_node_gyp (node “C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )
Building the projects in this solution one at a time. To enable parallel build, please add the “/m” switch.
C:\Users\SMOKE\AppData\Roaming\npm\node_modules\forgae\node_modules\argon2\build\libargon2.vcxproj(20,3): error MSB4019
: The imported project “C:\Microsoft.Cpp.Default.props” was not found. Confirm that the path in the declaratio
n is correct, and that the file exists on disk.
gyp ERR! build error
gyp ERR! stack Error: C:\Program Files (x86)\MSBuild\14.0\bin\msbuild.exe failed with exit code: 1
gyp ERR! stack at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\build.js:262:23)
gyp ERR! stack at ChildProcess.emit (events.js:198:13)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
gyp ERR! System Windows_NT 10.0.17763
gyp ERR! command “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\Users\SMOKE\AppData\Roaming\npm\node_modules\forgae\node_modules\argon2
gyp ERR! node -v v10.16.3
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] install: node-gyp-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\SMOKE\AppData\Roaming\npm-cache_logs\2019-10-15T19_57_09_573Z-debug.log

i think the error is from the argon lib??? not sure

Check your version of Python. That was the issue for me. I downgraded to Python 2.7.16 and I was able to successfully install/build. Also do no npm i -g forgae. Do npm i -g aeproject

Using python 2.7.16 also tried npm i -g aeproject same error, not giving up though would try make sure it works incase some others have same issues i can assist them, could you please look at the error code and the picture too to see if you could assist
thank you

@Enokela the issues is from the argon lib, this a dependency of the js-sdk, which is the main lib in aeproject. Here is a guide for the argon lib issues:

We will try to reproduce the issue and help you.

Martin

@Enokela did you run SET VCTargetsPath=C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140
before npm i -g aeproject?

No i didn’t let me try that now.

Okay i would wait for that then cos it still returns same error, Thank you all do much