Aeproject deploy issue

Hi, having issues with deploying my contracts on the testnet, it worked fine before.
Error: getaddrinfo EAI_AGAIN

(node:20281) UnhandledPromiseRejectionWarning: Error: getaddrinfo EAI_AGAIN
at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:60:26)
(node:20281) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not h
andled with .catch(). (rejection id: 2)
(node:20281) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Anybody with this problem?

The error shows a DNS problem. Trying again should fix the issue, if it doesn’t it could mean the node you are trying to connect is likely offline. The hint is the error code the SDK returned: EAI_AGAIN while issuing a getaddrinfo call.

1 Like

Thanks for the tip @arpunk.chain
Tried for more than a few times in the last 2 hours. Updated the aeproject to newest version and still the same.
I checked, seems to be working

1 Like

Hello @dusan!

Have you tried to include more options to the deploy command related to the testnet like: networkId, compiler, and network url?

This command works well for me:

aeproject deploy --network "" --networkId "ae_uat" --compiler ""

No, it behaves exactly the same.
I used the command above before, it worked perfectly, not sure what is going on right now, I had no changes to the setup

The issue persisted but I found the problem.
I tried pinging the sdk-testnet address, here is what I got

PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=245 time=12.6 ms
64 bytes from ( icmp_seq=2 ttl=245 time=11.5 ms
64 bytes from ( icmp_seq=3 ttl=245 time=13.4 ms

So I changed the command to use the response address and it worked! Here is the full command which works if other people get stuck, hope it helps

aeproject deploy -s YOUR_PRIVATE_KEY --network "" --networkId "ae_uat" --compiler ""

1 Like

Hello all,

@martingrigorov.chain can you help here?

Yes, we will investigate the issue and comeback.