Aeternity Windows Release (experimental) - Call for Testers

This is an experimental packaged build of the epoch aeternity node.
It is intended to be used for experimentation.
Be aware that this package has not been tested extensively.


We are looking for users who are willing to test this experimental release and report back any issues found when using it.

Supported Windows Versions

  • Windows 10 64bit
  • For CUDA mining a very recent NVIDIA driver version is required (tested with version 417)

Included Functionality

Node Version

1.3.0, most information from the aeternity Release Notes apply.

Additional Features


Known Issues

  • Key generation through the command-line like ./bin/aeternity keys_gen PASSWORD is not possible
  • No GPU mining using AMD cards possible
  • Launching the node opens 2 windows. The first one shows some errors which can be ignored (black backround) can be closed.
    The second window (white background) shows the running node.

Currently Investigating

  • First window opens (black background), but no second window (white background) does not open

Getting Started

  1. Download the zip package and unpack it into a separate folder.
  2. Open the configuration file <PACKAGE_BASE>/epoch.yaml and replace the entry for beneficiary with a valid value.
  3. Start the node by double-clicking <PACKAGE_BASE>/aeternity.exe.
  • Let the node run until it reports that the chain sync has been completed.
  1. Stop the node by closing the window.
  2. Enable CPU mining by setting the entry for autostart to true in the configuration file.
  3. Start the node again by double-clicking <PACKAGE_BASE>/aeternity.exe.
  • You can follow the mining output in the log files <PACKAGE_BASE>/log/epoch_mining.log and <PACKAGE_BASE>/log/epoch_pow_cuckoo.log.
  1. (Optional) Enable CUDA mining by configuring the mining section of the configuration file as documented in that file.


Version 1.3.0-experimental.1 - Tue Jan 29 09:23:12 UTC 2019

SHA512( 0293f6049661c074fc919ad9b006a54dc53294a18ef15a3730acb1af0f25bbbd805e5b11b81fdfda6916b93cdd429daad310239d28d909ba04f817d687033cb4
SIZE( 38992224 bytes

Version 1.1.0-experimental.1 - Wed Dec 17 19:11:11 UTC 2018


SHA512( = cef6ea24622ac5d3f16e179a35dba35cec32bc9eeb3318c0cc9a5c33c1646d570e35d93f31f158e9d94dc2539023474d7c75fff10b180ff1f1d741a502b850b6
SIZE( = 35675310 bytes

Version 1.0.1-experimental.3 - Wed Dec 5 21:22:43 UTC 2018


SHA512( = 5a20e54eb718cd016c5891b3ed2cee3a1a92085635f9b141624d8fc3af4f9db60c44553ae2b668c799a5b41ace5457d93238eb91bfd66e71af3037c989a15730
SIZE( = 36530932 bytes

Version 1.0.1-experimental.2 - Wed Dec 5 20:14:57 UTC 2018

NOTE: The mining logic in this version is broken, please don’t use it if you are looking to mine!

SHA512( = 996751521a65c9ac3a6bc9a5e7805305d81cf6aab876bcec3a30cbe43166e767c41174d6f49186ec4490b3e1f3f1adb075d40867c26245c8a2008663178b7bf6
SIZE( = 36530900 bytes

Version 1.0.1-experimental - Wed Dec 5 18:14:57 UTC 2018

NOTE: The node startup in this version is broken, please don’t use it!

SHA512( = ac44f3ae9080c22bfc25506aa9766a835af1e488ada1f0a9687961158c3e9059e1cc666aae9f9b7444310b02fa42770514d09938c0d7e3ce7a74a2fe8508d5e3
SIZE( = 36530829 bytes

More Information


Please report any feedback to the Github project or the forum post dedicated to this release.

Ideally you should include the following information in your report:

  • aeternity windows package version
  • Windows version
  • NVIDIA GPU type and driver version when trying to mine using the CUDA miner
  • aeternity logs and configuration file uploaded via Pastebin or somewhere else

Thanks in advance, and happy testing.


I will try it. Does it work with AMD GPUs as well or only Nvidia ?

I tried running this on an old laptop (i7 3612qm). Started fine and synced until the latest block according to

Changed mining to “true” and it crashed right away. Changed it back to false but now it is crashing as soon as it starts. Maybe I am misunderstanding, but this is supposed to work with CPU only as long as I am not enabling CUDA? (This laptop only has Intel GPU).

Crash dump:

1 Like

It is NVIDIA-only at the moment, because it uses the same mining code as the official releases.

Correct, you should be able to use your CPU. Thanks for the crash dump, I’ll look into it.

Failed for me.

Running ./usr/lib/epoch/bin/epoch.cmd…
‘findstr’ is not recognized as an internal or external command,
operable program or batch file.
‘findstr’ is not recognized as an internal or external command,
operable program or batch file.
‘findstr’ is not recognized as an internal or external command,
operable program or batch file.
./usr/lib/epoch/bin/epoch.cmd exited with status 0.
Press return to close this window.

That is expected and fine. The second window which opens should show the running node.

no second window opens if you are referring to my post

Tried a new attempt.

I got the second window on my laptop and managed to sync. It crashed the second time I opened it, even without adding “true” to mining.

On my desktop I did not get any second window.

Yes I was. Are there any logs in <PACKAGE_BASE>/log or a crash dump at <PACKAGE_ROOT>/erl_crash.dump?

i don’t see either of those. would it be directly in epoch folder?

It should either be in the top folder which you’ve extracted the zip file to, or possibly in the usr/lib/epoch folder within that top folder.

I’m creating a new release which fixes you first issue.

The start up issue is fixed in the new version, see first post.

Regarding the non starting node on the second machine: Can you check in the taskmgr whether there are any erl.exe processes running?

Tried new version, still nothing showing up on second machine, no erl.exe.

Still syncing on the first machine, will see if it manages to not crash on second startup / with mining.

Could you post an example config file for reference with actual values filled in?


This is what I get, is this OK?

not sure i configured the instances right for gpu’s. afterburner shows know usage.