Aeternity Windows Release (experimental) - Call for Testers


My bad, forgot to mention that you need to backup your database directory and start from scratch. So in steps:

  1. Stop node.
  2. Move directory ./mnesia to ./mnesia_backup.
  3. Start node with different local network id.
  4. Verify it works.
  5. Stop node.
  6. Delete directory ./mnesia and move directory ./mnesia_backup to ./mnesia.
  7. Start node with network id ae_mainnet.

The reason behind this is that the state of your local data depends on the network id. So you can’t share that data between networks and have to start from scratch if you want to experiment like this. However, since you don’t want to sync the full chain again later, you should backup the ae_mainnet data.


keeps saying connection handshake failed after step 3


No, windows starts work incorrecty and only reset helps. There is no crash damp. I got same error "solution no found’ in local test net.


You can ignore these errors. Your node won’t be able to connect with other nodes since you are using a custom network id. The important bits are in the mining and pow log files. At some point these should show a block mined.



Please read if you are a node operator or miner:



yes. still doesn’t show cuda29 running on processes and no log files are created.


-d 1
Use that with a number from 0 to N


There is no “-e” parameter, the parameters are case sensitive and the correct one is “-E”


what is this in reference to? the -d 1


So the node console (white window) is running, which is where you see the log messages, but no log files are created?


To select what cuda device to use, you use “-d #” which is a list of cuda devices starting with 0.

It was an answer to SXC


Create a wallet in aepps or airgap, then use the address, and only the address, in the beneficiary field.


Just to troubleshoot, can you find the cuda29.exe and call it from a terminal? show what it says when you run it here.


Did you solve your problem?


“Solution not found” is not an error, it just means that this particular mining attempt (this cuckoo puzzle) was not successful. That is expected.


I just try to launch mining on localtestnet, and my 11-card rig get 3 sol for 3 min ±.
Message "parse_generation_result:454 Solution found: " in log. And there is no one solution for 10 min in mainnet. What a dramatic performance…


Not sure I am following what you mean. But if you are saying that you mined 3 blocks in 3 minutes on a local network that sounds reasonable. And I am not terribly surprised that you did not manage to mine a block in 10 minutes on the mainnet either. So what is the problem/question?


Question is: Does "parse_generation_result:454 Solution found: " means that i found the block? I thougt that solutions not equial block. In ubunt i saw solutions but not reward for blocks.


The debug logging in log/epoch_pow_cuckoo.log is changed between versions - I’d look in log/epoch-mining.log for log entries like:
2018-12-06 16:29:58.599 [info] <0.399.0>@aec_conductor:handle_mined_block:847 Block mined: Height = 3; Hash = ad60e70f02f519c409e22d6eb10c4f1c0c6b9255055928ffd3fccd7b177ba9e8


Is it windows version log?