Base aepp 0.12.0 and aepps issue with LIMA

Hey guys, me again :slight_smile: I was checking with @stoyan.chain on my governance app that it’s almost 100% ready for LIMA. Actually it works fine without base aepp, bringing info from my smart contracts and everything. When I try it from the last base app version I get:

Compiler 3.2.0 support only consensus protocol less then 3(Fortuna)

It doesn’t seem that my aepp (unless wallet) has anything to do with this because otherwise it shouldn’t work without base aepp.

This is my aepp:


@noandrea will definitely know this :slight_smile:

hello @ae-omar, currently aeternity testnet and mainnet networks are in a “divergent” state, from the Lima protocol (v4) you are required to use the compiler v4.x, while before you must use a compiler version < 4.

the current state of things is that testnet has switched to Lima protocol but mainnet has not (details here).

In this case the javascript SDK has a built in check to warn you about this incompatibility but unfortunately the message is misleading (should be Compiler 3.2.0 support only consensus protocol less then 4(Lima)

summing up, if you are on testnet you should use while on mainnet the is the compiler you want.


Thank you @noandrea, I came here for the same issue, and solved using latest for testnet :+1:

1 Like

Thanks @noandrea I’m aware of that, and that’s why it’s weird because my aepp is using updated sdks, compiler and node and it works without base æpp. So, maybe I’m forgetting something related to base æpp or maybe some part of the base æpp is using old stuff.

@noandrea I think this is related with my issue.
Base apps seems to be pointing to older compiler so when I run my aepp trough base app it takes that compiler url instead of mine (

Could it be?

for those following Dacade 101 how do we fix this @moritzfelipe ???

1 Like