Can't mine with GTX 1050 4GB

Hi! I have a GTX 1050 4GB mobile but I can’t mine æ. The problem I get is:

Failed to initialize miner on GPU0: MSI GeForce GTX 1050 4GB [0000:01:00.0]: out of memory

for Gminer and

Device 0:
    Name:    GeForce GTX 1050
    Address: 1:0
    Vendor:  NVIDIA Corporation
    Memory:  4096 MByte
    Active:  false (Memory check failed for kernel Cuckoo 29, 6G)
Device 1:
    Name:    Intel(R) HD Graphics 630
    Address: 4294967295:4294967295
    Vendor:  Intel(R) Corporation
    Memory:  6521 MByte
    Active:  false (not selected)

Connecting to pool...
Connected to ae.2miners.com:4040  (TLS disabled)
Subscribed to stratum server
Authorized worker: ak_aQtZcwia4WuD2J8aQFFB44eNto7QoBERFKBinzZcqxoojRBNo.WorkerName
New difficulty received: 16
New job received: 55fd Height: 384060
Start Mining...
All devices deselected or failed compatiblity check.

for lolminer.

I know some might say don’t mine from your laptop but my temps are ok so that’s is not a problem. My intel graphics card is outputting the screen so the memory isn’t used by my screen. I checked my available graphics memory via hwinfo and I had 4021 MB free memory only 75MB was used. Can you help me with mining æ is there something I am missing like a config setting or smth ?

Unfortunately you need more than 4GB of memory, the Cuckoo POW algorithm is about finding cycles in a large graph so it requires a large chunk of memory (somewhere between 6 and 8 GB, can’t remember exactly…)

2 Likes