Error Cannot find module 'aeproject-utils'

Hi i am following this tutorial

but when i am on the last step for deploying the contract i get this error

(node:8657) UnhandledPromiseRejectionWarning: /Users/federico/aeternity/myFirstAepp/node_modules/aeproject-lib/dist/aeproject-deployer.js:1
Error: Cannot find module ‘aeproject-utils’
Require stack:

  • /Users/federico/aeternity/myFirstAepp/node_modules/aeproject-lib/dist/aeproject-deployer.js
  • /Users/federico/aeternity/myFirstAepp/node_modules/aeproject-lib/dist/index.js
  • /Users/federico/aeternity/myFirstAepp/deployment/deploy.js
  • /usr/local/lib/node_modules/aeproject/aeproject-deploy/deploy.js
  • /usr/local/lib/node_modules/aeproject/commands.js
  • /usr/local/lib/node_modules/aeproject/aeproject-cli.js
    at Object. (/Users/federico/aeternity/myFirstAepp/node_modules/aeproject-lib/dist/aeproject-deployer.js:21:43)
    at Object.Module._extensions…js (internal/modules/cjs/loader.js:991:10)
    (node:8657) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)
    (node:8657) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Hey @martingrigorov.chain or @alekseytsekov.chain can you help here please?

Hey @federicobouchaton could you please first go through this guide and try again.
https://aeproject.gitbook.io/aeproject/developer-documentation/aeproject-library-api/deployer

Best,
Martin

2 Likes

Hi @martingrigorov.chain i tried what you suggested but i am still having the same problem.
Sorry i am not seeing what i am doing wrong

Hi @martingrigorov.chain any update here?

Have you tried calling the command without sudo?

I tried without sudo and still having the same issue

Here is a video of the steps i am doing

Hey @martingrigorov.chain can you take a look, please?

We will try to investigate, yes.

1 Like