How transfer AEs from local wallet (epoch node)?


#1

Hi, I have a wallet in local, epoch node.
The account was generated with the command “./bin/epoch keys_gen password”, this command created two files “key.pub” and “key” in “generated_keys” directory.

I tried use aecli util, but is not possible to use this key files, How transfer this AEs to other wallet?

Thank you.


#2

Hello!

Maybe this will help:

Best,
Vlad


#3

Not the most user-friendly, but a way…


#4

another guide to do so: https://hackmd.aepps.com/KwdgHATARgpghlAtBAnAExYgLAYwGYiJx4DMwiaclAbCQAwk5prBA===


#5

Thank you, how long does it take?

The last point is:

“The transaction should now be pushed to the transactions pool to be picked up by miners in the next blocks”

Its has been 2 hours since command “aec_tx_pool:push(SignedTx).” was executed but I do not see transaction in wallets.


#6

It normally takes a few seconds upto a few minutes for a transaction to be picked up by the current leader…

I checked my mempool, and there are no valid transactions there waiting to be picked up (I see 6 with old nonces and one where the sending account has too little funds)… Which account did you try to send from?


#7

duplicate reply removed


#8

{ , Sender_pub_key} = aehttp_api_encoder:decode(<<“ak_2EBTYibGgWmTF5ngtQsxywBHmc4wYJTGyWdAAraJkmBNAyKFB2”>>).
{
, Recipient_pub_key} = aehttp_api_encoder:decode(<<“ak_2n28C4HLrFRrKRsgvQHhvJcQz5aiFhjTzGBBAXb2cps6ea53ud”>>).

and

Amount = round(3.0e18).
Fee = 200000.
Nonce = 1.

are ok?


#9

I see no traces of such a transaction in the mempool (nor on the chain) - is your node connected to the chain? Is it in sync?

You can double check that the transaction was successfully added to the mempool by peeking into it:

9> rp(aec_tx_pool:peek(25)).
{ok,[{signed_tx,{aetx,spend_tx,aec_spend_tx,88,
                      {spend_tx,{id,account,
                                    <<84,78,224,1,247,16,88,34,179,115,175,122,24,77,...>>},
                                {id,account,
                                    <<239,95,62,173,116,109,106,160,30,122,217,88,248,...>>},
                                357000000000000000000,20000,0,1,<>}},
                [<>]},
      ...]}

If everything worked you should find your SignedTx in there…


#10

Hi, I executed first in other terminal “curl http://35.178.61.73:3013/v2/blocks/top” and “curl http://127.0.0.1:3013/v2/blocks/top” and both return the same block.

Is this sync mode correct? Is there another way?

Thank you.


#11

That sounds correct. Then you should verify that your transaction is added to the mempool, by running the command in my last reply. Also pay attention to the result of aec_tx_pool:push(SignedTx), if all is good it should be ok.


#12

This command return “Ok” in console, but not changes un wallets…


#13

Hi again, transaction are ok but hours later. Six or seven hour has taken, is it normally?


#14

Good that the transaction made it eventually, but it sounds like something isn’t working optimally. Have you updated to version 1.0.1? (It does improve the transaction gossip)


#15

I use Roma versión, but multigpu branch one week ago.


#16

I suggest you try this one: