Mining with Cuda miner issues - Node mines on wrong hash


#1

Hi aeternity team!

I’ve been successful in building the cuda miner and getting it to engage, but I’m having a couple troubles. Maybe someone has an answer or these are known issues.

  1. When GPU mining, the node does not seem to advance to the next block and reports the same block hash and height as the network. Referencing the instruction provided in docs/operation.md #Verify that node mines on same chain as the testnet. This does not occur when CPU mining. Removing section mining.cuckoo.miner from epoch.yaml and restarting the node gives the expected result of the local node being one block ahead of the network.

  2. The network is rejecting Cuckoo Cycle? When running with the CUDA cuckoo cycle miner, the following message is spammed in the epoch_mining.log file:
    [info] <0.1223.0>@aec_conductor:handle_add_block:898 Header failed validation: incorrect_pow
    Is the testnet not currently on Cuckoo Cycle?

I would be glad to assist in any way I can with logs, system info, etc… I’m really excited for this launch and want to be as ready as possible!

Thanks!


#2

Hey @w00table,

Thank you for your question - we’ve forwarded it to the dev team and they’ll get back to you.

Regards,
The AE Team


#3

Thanks. This was done on 0.18.0 by the way, since binaries for 0.19.0 aren’t up yet.


#4

Hey @w00table,

Did you set any value for mining.cuckoo.miner.hex_encoded_header ? If yes, which one?
Could you please retry by setting that to true?

Let us know if that helps,
The AE Team