Problem starting a node with ForgAE 3.0.0 on Ubuntu 18.04

Hi, i’m playing around with forgae and trying to start a node. Unfortunately this is what i get - any advice?

===== Starting node =====
(node:28465) UnhandledPromiseRejectionWarning: Error: spawn docker-compose ENOENT
    at _errnoException (util.js:1022:11)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:190:19)
    at onErrorNT (internal/child_process.js:372:16)
    at _combinedTickCallback (internal/process/next_tick.js:138:11)
    at process._tickDomainCallback (internal/process/next_tick.js:218:9)
(node:28465) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:28465) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

I think @MartinG you should be able to help me here?

seems like you haven’t installed docker-compose on your machine

@emin what OS are you using, have you installed docker on the machine?

1 Like

I have docker-compose and still have a problem when trying to compile.

[email protected]:~/Documents/Aeternity Development/Forgae/test$ forgae node
===== Starting node =====
.Recreating test_proxy_1 ... 

Recreating test_node1_1 ... 

Recreating test_node2_1 ... 
Recreating test_node1_1 ... done
Recreating test_proxy_1 ... done
Recreating test_node2_1 ... done
Recreating test_node3_1 ... done
.
.
..........................
===== Node was successfully started! =====

[email protected]:~/Documents/Aeternity Development/Forgae/test$ forgae compile
===== Compiling contracts =====

Contract '/home/emmanueljet/Documents/Aeternity Development/Forgae/test/contracts/ExampleContract.aes has not been compiled'
reason:
connect ECONNREFUSED 127.0.0.1:3080

Note I have localhost installed

@emmanueljet the node seems to be started, but I don’t see the compiler started. When compiling smart contracts you need to spawn the compiler also. usually, this is done by the forgae node command but in your case, something is missing. Can you share which version of forgae are you using? Also, do you see docker-compose.compiler.yml file in your project? When you start everything with the forgae node can you check with docker ps or docker-compose ps which containers are running and share them with us?

Thanks

Everything is working perfectly well now, my contract has been compiled and deployed.

[email protected]:~/Documents/Aeternity Development/Forgae/test$ forgae compile
===== Compiling contracts =====

Contract '/home/emmanueljet/Documents/Aeternity Development/Forgae/test/contracts/ExampleContract.aes has been successfully compiled'
Contract bytecode: "cb_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"

Deployment Output

[email protected]:~/Documents/Aeternity Development/Forgae/test$ forgae deploy
===== Contract: ExampleContract.aes has been deployed at ct_HVb6d4kirgqzY1rShmzRTRwukcsXobjHcpLVD2EggoHmn6wt2 =====
Your deployment script finished successfully!

Is there a way I can view this deployed contract like the testnet explorer?

@emmanueljet glad that everything worked for you. Can you share how you fixed it, maybe it could help @emin to solve his issue to.

You should be able to, you can check in the explorers if they support testnet with the contract address that is logged into the console. You can also use the middleware I thinkg to track this. If you need the transaction info you can log the result from the deployment in you deployment script or you can use forgae history command to check latest deployments

Cheers,
Martin

1 Like

I made us of the link below to install docker which comes with the docker-compose

Regards,
JET

1 Like

I have seen this, thank you.

Mainnet link: https://mdw.aepps.com
Testnet Link: https://testnet.mdw.aepps.com

Regards,
Emmanuel Joseph

1 Like

@MartinG anytime i run forgae node i get .Cannot start AE Node!
and anytime i run forgae compile i get connect ECONNREFUSED 127.0.0.1:3080
and whats this fuzz about forgae renamed to AEproject

@Goodness is there any error message with this?