[Solved] ./bin/epoch start no response


#1

2018-11-30 19:16:18.597 [info] <0.958.0> Application lager started on node [email protected]
2018-11-30 19:16:18.597 [info] <0.958.0> Application aens started on node [email protected]
2018-11-30 19:16:18.597 [info] <0.958.0> Application aecontract started on node [email protected]
2018-11-30 19:16:18.597 [info] <0.958.0> Application aeoracle started on node [email protected]
2018-11-30 19:16:18.597 [info] <0.958.0> Application aecuckoo started on node [email protected]
2018-11-30 19:16:18.598 [error] <0.1061.0>@gen_server:init_it:357 CRASH REPORT Process exec with 0 neighbours exited with reason: bad return value: “Port program /aenode/lib/erlexec-1.7.1/priv/x86_64-unknown-linux-gnu/exec-port with SUID bit set is not allowed to run without setting effective user!” in gen_server:init_it/6 line 357
2018-11-30 19:16:18.598 [error] <0.1060.0> Supervisor exec_app had child exec started with exec:start_link([]) at undefined exit with reason bad return value: “Port program /aenode/lib/erlexec-1.7.1/priv/x86_64-unknown-linux-gnu/exec-port with SUID bit set is not allowed to run without setting effective user!” in context start_error
2018-11-30 19:16:18.598 [error] <0.1058.0> CRASH REPORT Process <0.1058.0> with 0 neighbours exited with reason: {{shutdown,{failed_to_start_child,exec,{bad_return_value,“Port program /aenode/lib/erlexec-1.7.1/priv/x86_64-unknown-linux-gnu/exec-port with SUID bit set is not allowed to run without setting effective user!”}}},{exec_app,start,[normal,[]]}} in application_master:init/4 line 134
2018-11-30 19:16:18.599 [info] <0.958.0> Application erlexec exited with reason: {{shutdown,{failed_to_start_child,exec,{bad_return_value,“Port program /aenode/lib/erlexec-1.7.1/priv/x86_64-unknown-linux-gnu/exec-port with SUID bit set is not allowed to run without setting effective user!”}}},{exec_app,start,[normal,[]]}}


#2

I think you are running as root perhaps? See the troubleshooting guide: https://github.com/aeternity/epoch/wiki/Troubleshooting#node-wont-start-with-privileged-user


#3

Thanks :star_struck: