[Solved] Cannot start AE Node!

I have problems to start the node throws me the following message: Cannot start AE Node!
OS: Ubuntu 18.04.3 LTS

1 Like

Without knowing a bit more what you have done it is hard to know why it doesn’t work. I assume you have followed the installation instructions?

You are trying to run the latest version (5.2.0)? You have installed the necessary dependencies (libsodium and openssl)? The node logs to various files in the <node>/log/ directory is there anything there that indicates why it could not start?

effectively followed the instructions and the version is this 5.2.0, the dependencies are also installed, I will concentrate on the log, to see what may be happening, thanks

the docker-compose version was 1.25.0, install 1.24.0. thanks

Hey @marcojgomezm.chain,

Can you confirm you were using aeproject?
If this is the case - could you please check this topic out.

Seems you had similar problem
Cheers!

1 Like

Ubuntu 18.04.3 LTS
aeproject 2.1.0
Python 2.7.15+

Did you check the topic?
If this did not help you, could you please be more specific how we could reproduce the issue, so we could further investigate?

Thank you!
Hris

I managed to make the compilation by installing the previous version of docker-compose 1.24.0, since it was 1.25.0, now I have a problem with the test unit

Hey @marcojgomezm.chain,

Seem you have not run your compiler?
Could you confirm you started your environment with aeproject env?

For your convenience you could run aepriject env --info to see if both node and compiler instances are running.
You could also refer to the documentation for more details.

I look forward to hearing from you!

good afternoon thank you for the prompt response, here the screen with the results

change the version of nodejs from v8.11.1 to v9.11.2 and throw this error at me, then go back to v8.11.1 and it appears

grateful for the collaboration

Do you have this project uploaded on GitHub, so i could take a look?

Hris

That is an example that I am trying to recreate, annex the web reference and and the repository

https://hack.bg/blog/tutorials/build-your-first-decentralized-application-aepp-on-aeternity-blockchain-sophia-smart-contract-address-book/

https://github.com/mradkov/addressbook-aepp-aeternity

I’m sure @milenradkov.chain can help here when he has some time.

1 Like

Hello @marcojgomezm.chain,

Actually this tutorial is almost a year old and there was a lot of development and improvements happening in the tools and Sophia since.

I’ll go over and update it with the latest changes asap.

Will let you know when this is done so you can try again :slightly_smiling_face:

1 Like

Updated the code and the tutorial. @marcojgomezm.chain @emin.chain

I also followed it from the beginning it should be working fine if you follow everything step by step.

Merry Christmas.

4 Likes

Excellent, in what you run the tests I will be reporting the results, Thank you

1 Like

Cool! Good job. Will also play around with it a bit.

1 Like

Good evening Milen Radkov, I already did the tutorial run and everything worked, just some configuration details but they were resolved. Very grateful for your support, regards

image

3 Likes