[Solved] [Forum] Waellet contract call fail

Hi there. I keep getting the error “Account not connected. Establish connection first” when trying to do a contract call via window.Aepp.request.contractCall method. Happens both on chrome and firefox, newest extension installed. Please help :slight_smile:

Probably @milenradkov.chain would need some more info for your setup.

No prob, just tell me what you need?
I use windows with both Chrome and Firefox, same error. installed the newest version of Waellet, created an account, logged in into the account. Using testnet.

I tried directly in the developer console, calling window.Aepp.request.contractCall() and got the same error, here is the full error message:

error: Object { code: 1, data: {…}, message: "Account not connected. Establish connection first" }
id: "c59b4a64-0847-4b3e-ba1d-bad0414c2fad"
jsonrpc: "2.0"
method: "aeppMessage"
resolve: true

Parameters to the contractCall function are (CONTRACT_SOURCE, CONTRACT_ADDRESS, ENTRYPOINT_NAME , args = [‘ak_Sq4TqxBH5KG6UqgUfgAe2UeCJsgYCCjgsFEjLQwysnbVJrHtb’, ‘12’])

This happened with several different deployed contracts (they are tested and working)

Probably worth mentioning. I also tried calling the window.Aepp.request.signMessage function and I was getting the same error.

Please check the documentation here: https://github.com/waellet/waellet/wiki/Aepp

And also there is an example boilerplate aepp https://github.com/waellet/waellet-aepp-boilerplate

3 Likes

Ok, this helps. So I basically need to start with the connect method and then use the object further.

Here is the example code just to have it visible here as well

Aepp
.request
.connect()
.then(result => console.log(result))