[Solved] Is there a mining tutorial for mainnet?


#1

Hi friends,

is there a mining tutorial for mainnet? I followed the tutorial https://blog.aeternity.com/tutorial-mining-ae-on-ubuntu-18-04-f4d1f908b0fd and try to set up but didn’t success. I defined the epoch.yaml and run command to test it but encountered the error “yamerl_parsing_error, error, “Block mapping value not allowed here””.

I want to use CPU mining based on AE mainnet. any help?

thanks in advance.


#2

@iFeelUing
It looks like your epoch.yaml file is misconfigured. Could you please paste the mining section of it?


#3

Hi friend, yes, solved already. thx.


#4

BTW, how to involve multiple CPU cores to mine? friend.


#5

The field extra_args in epoch.yaml can contain an option -t N where N is the number of threads/cores to use by the cpu-miner.


#6

after i added this:

mining:
beneficiary: “ak_47wX83aFZTNmjcHAMohgPfp3GrAuiiMqoK13Ckmp6Cn7tHi43”
autostart: true
cukcoo:
miner:
executable: lean30
edge_bits: 29
extra_args: “-t 6”

the mining will throw error said “2018-11-30 20:34:19.906 [error] <0.1267.0>@aec_conductor:handle_mining_reply:718 Failed to mine block, runtime error; retrying with different nonce (was 1746218179646316195). Error: {execution_failed,{status,127}}”

do you know why?


#7

It should be lean29 I think :thinking:


#9

I tried but without success. the error is “2018-12-01 00:27:20.550 [info] <0.3324.0>@aec_conductor:add_synced_block:150 Header failed validation: incorrect_pow”


#10

That error suggests there is a problem with your configuration. Could you post the whole configuration? The relevant bits for incorrect_pow should be expected block time and edge_bits


#11

Hi friend, the executable parameter should be “mean29-generic”. and the mining program keep running a whole night. but I didn’t see any mined block via command “grep “mined” log/epoch_mining.log*” to check. is this normal?
CPU model is below.
vendor_id : GenuineIntel
cpu family : 6
model : 62
model name : Intel® Xeon® CPU E5-2680 v2 @ 2.80GHz
stepping : 4
microcode : 0x42c
cpu MHz : 2799.999
cache size : 25600 KB


#12

The mining power of the network is strong enough that you should not expect to mine a block using CPU-mining ‘in a night’. You could get lucky of course, but normally it will take longer.