[Solved] Issue with AEProject

Hey guys its me again lol :sweat_smile: … i’m having issues running aeproject.
When i run aeproject env i get this error:

===== Starting node and compiler =====
.(node:12964) UnhandledPromiseRejectionWarning: Error: Process exited with code 1
at ChildProcess.done (C:\Users\ALEX PC\AppData\Roaming\npm\node_modules\aeproject\node_modules\promisify-child-process\index.js:42:47)
at ChildProcess.emit (events.js:198:13)
at ChildProcess.EventEmitter.emit (domain.js:448:20)
at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
(node:12964) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:12964) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
…===== Node was successfully stopped! =====
===== Compiler was successfully stopped! =====
Cannot start AE Node!

Any help???

Hey Emanuel,

Sometimes this error is originated due to the fact you have your docker turned off.
Could you please provide some reproduction steps?

Thanks in advance!

Hris

Hey metselder,

Firstly docker could not be installed on Windows10 home edition. So i had to follow this tutorial https://www.sitepoint.com/docker-windows-10-home/. I was able to get everything setup. So i ran it in my oracle VM Virtual Box and it runs fine. It shows the server is up and running but anytime i run aeproject node after a couple of minutes i get the error stated above. Could it be that it cannot work on Windows10 home edition?

We provide support for windows so this is not to worry about :slight_smile:

Could you please confirm your docker-compose version.
Also, you might be interested in looking at this topic.
Seems you had similar issue.

Please share with us if you need any further assistance, or you managed to run your local env.

Regards,
Hris

2 Likes

Ok after researching I figured out docker could not be properly installed on windows 10 home because enabling hyper V isn’t supported on windows10 home. So I followed this little hack or tutorial https://www.sitepoint.com/docker-windows-10-home/
On how to install docker on windows 10 home and after completion aeproject node won’t still start the node with docker running concurrently

docker compose version 19.03.3,

1 Like

Hey @Emmanuel,

Have you tried with docker-toolbox? Also which version of aeproject you are working with? What is the error when trying to start the node?

Are you sure that this is the right version of docker compose?

Best,
Martin

As far as I can see the latest version of docker-compose is - 1.25.3 released several days aao (2020-01-23)

And latest docker toolbox version is v19.03.1 so I am not so sure what version do you have.

1.24.0, sorry for the mistake, this is my docker compose version

Hi guys. Followed these instructions verbatim.

Running the project

  • Create an empty directory which will hold the node infraestructure, the identity provider and the MemeVote Aepp:
mkdir MemeVote-aeproject
  • Install aeproject globally
npm install -g aeproject
  • Initialize aeproject
cd MemeVote-aeproject
aeproject init
  • Clone the MemeVote daepp
git clone https://github.com/aeternity/aepp-aeproject-js

  • Clone aepp-aeproject-shape-vueI have forked this awesome project because it includes the base functionality of the identity provider, which is in other words a configurable wallet. This fork add some UI improvements that facilitates the configuration and connection to the network from the browser.
git clone https://github.com/snaphuman/aepp-aeproject-shape-vue.git 

On each cloned repository folder (MemeVote and aepp-aeproject) fetch all their
dependencies.

npm install

  • Run both applications
# In Meme vote folder run:
npm start

# In aepp-aeproject-shape-vue run:
npm run serve

but once I went to npm start and npm run serve I received these errors

Leo-1:aepp-aeproject-js user$ npm start
npm ERR! missing script: start

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/user/.npm/_logs/2020-02-19T05_38_39_325Z-debug.log
Leo-1:aepp-aeproject-shape-vue user$ npm run serve
npm ERR! missing script: serve

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/user/.npm/_logs/2020-02-19T05_29_28_647Z-debug.log

didnt see a script to enter for serve or start in the package.json so I’ve clearly missed something

.json for js

{
  "name": "aeproject-monorepo",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "test": "mocha ./test/**/*.js --timeout 0 --exit",
    "aetest": "aeproject test",
    "link": "lerna bootstrap && cd packages/aeproject-cli && yarn link",
    "develop": "lerna bootstrap && cd packages/aeproject-cli && yarn link && cd .. && cd aeproject-config && npm install && yarn link && cd .. && cd aeproject-logger && npm install && yarn link && cd .. && cd aeproject-utils && npm install && yarn link  && yarn link aeproject-logger && cd .. && cd aeproject-lib && npm install && yarn link && yarn link aeproject-config && yarn link aeproject-logger && yarn link aeproject-utils",
    "develop-npm": "lerna bootstrap && cd packages/aeproject-cli && npm link && cd .. && cd aeproject-config && npm install && npm link && cd .. && cd aeproject-logger && npm install && npm link && cd .. && cd aeproject-utils && npm install && npm link  && npm link aeproject-logger && cd .. && cd aeproject-lib && npm install && npm link && npm link aeproject-config && npm link aeproject-logger && npm link aeproject-utils",
    "unlink": "cd packages/aeproject-cli && yarn unlink && cd .. && cd aeproject-lib && yarn unlink && yarn unlink aeproject-config && yarn unlink aeproject-utils && yarn unlink aeproject-logger && cd .. && cd aeproject-config && yarn unlink && cd .. && cd aeproject-utils && yarn unlink && yarn unlink aeproject-logger && cd .. && cd aeproject-logger && yarn unlink",
    "unlink-npm": "cd packages/aeproject-cli && npm unlink && cd .. && cd aeproject-lib && npm unlink && npm unlink aeproject-config && npm unlink aeproject-utils && npm unlink aeproject-logger && cd .. && cd aeproject-config && npm unlink && cd .. && cd aeproject-utils && npm unlink && npm unlink aeproject-logger && cd .. && cd aeproject-logger && npm unlink"
  },
  "dependencies": {
    "@aeternity/aepp-sdk": "7.0.0",
    "aeproject-lib": "^2.0.1",
    "esm": "^3.0.77",
    "fs-extra": "^7.0.1",
    "prompts": "^2.2.1"
  },
  "devDependencies": {
    "@typescript-eslint/parser": "^1.7.0",
    "chai": "^4.1.2",
    "chai-as-promised": "^7.1.1",
    "chai-files": "^1.4.0",
    "docker-cli-js": "^2.5.1",
    "eslint": "^5.15.1",
    "eslint-config-standard": "^12.0.0",
    "eslint-plugin-import": "^2.17.2",
    "eslint-plugin-node": "^8.0.1",
    "eslint-plugin-promise": "^4.1.1",
    "eslint-plugin-standard": "^4.0.0",
    "lerna": "^3.14.1",
    "mocha": "^5.0.0",
    "promisify-child-process": "^2.1.2",
    "shelljs": "^0.8.2",
    "sinon": "^7.1.1",
    "typescript": "^3.5.2",
    "yarn": "^1.21.0"
  }
}

.json for shape-vue which is confusing because I see a serve script

{
  "name": "vue-project",
  "version": "0.1.0",
  "private": true,
  "scripts": {
    "serve": "vue-cli-service serve",
    "build": "vue-cli-service build",
    "lint": "vue-cli-service lint"
  },
  "dependencies": {
    "@aeternity/aepp-components": "https://github.com/aeternity/aepp-components.git#develop",
    "@aeternity/aepp-sdk": "6.0.2",
    "vue": "^2.6.6",
    "vue-loading-overlay": "^3.2.0",
    "vuex": "^3.0.1"
  },
  "devDependencies": {
    "@vue/cli-plugin-babel": "^3.5.0",
    "@vue/cli-plugin-eslint": "^3.5.0",
    "@vue/cli-service": "^3.5.0",
    "babel-eslint": "^10.0.1",
    "eslint": "^5.8.0",
    "eslint-plugin-vue": "^5.0.0",
    "vue-template-compiler": "^2.5.21"
  }
}

Hi @Mike

  • install aeproject globally
  • in a new folder aeproject shape vue
  • in another folder clone your repo
  • install dependecies and run it

Best,
Aleksey

2 Likes

@alekseytsekov.chain thanks, is this the best way for building an angular app?

Hey all,

@alekseytsekov.chain Any follow-up here?

@Emmanuel Is your issue resolved?

1 Like

docker-toolbox seemed to be the solution

1 Like

I have the same problem. Is your problem resolved? @Mike