[Solved] Local node sync failed


#1

I created tow local node, node1 is miner, node2 sync from node1, but node2 only sync to height 2 and stop, from the log node2 shows:

2019-04-05 12:29:02.489 [debug] <0.1411.0>@aec_tx_pool:new_sync_top_target:230 new_sync_top_target()
2019-04-05 12:29:02.489 [debug] <0.1401.0>@aec_tx_pool:handle_cast:300 [8] Msg = {new_sync_top_target,0}
2019-04-05 12:29:02.489 [debug] <0.2694.0>@aec_tx_pool:do_update_sync_top:494 do_update_sync_top(0,91,<0.1401.0>), LocalTop = 2
2019-04-05 12:29:02.489 [debug] <0.1401.0>@aec_tx_pool:handle_info:318 [3] Msg = {<0.2694.0>,new_gc_height,91}
2019-04-05 12:29:02.493 [debug] <0.1411.0>@aec_tx_pool:new_sync_top_target:230 new_sync_top_target()
2019-04-05 12:29:02.493 [debug] <0.1401.0>@aec_tx_pool:handle_cast:300 [8] Msg = {new_sync_top_target,91}
2019-04-05 12:29:02.493 [debug] <0.2697.0>@aec_tx_pool:do_update_sync_top:494 do_update_sync_top(91,91,<0.1401.0>), LocalTop = 2
2019-04-05 12:29:02.493 [debug] <0.1401.0>@aec_tx_pool:handle_info:318 [3] Msg = {<0.2697.0>,new_gc_height,91}
2019-04-05 12:29:02.573 [info] <0.1404.0>@aec_conductor:handle_add_block:1017 Couldn’t insert received block ({root_hash_mismatch,<<222,212,24,121,132,9,130,152,132,131,114,39,193,215,97,100,25,33,95,113,220,230,59,128,62,16,224,70,240,94,150,90>>,<<136,49,63,113,121,66,70,198,242,81,121,148,164,95,6,144,223,197,241,109,78,195,27,198,63,98,80,158,12,229,14,135>>})

aeternity.yaml of node1 is:

aeternity.yaml of node2 is:


#2

aeternity version 2.2.0


#3

Hello,
I see you are missing beneficiary_reward_delay from the configuration of the second node. This parameter is under consensus, try to set it to the same value. You shall delete node2 database as well.

Otherwise the configuration looks OK to me.

Let’s me know if that helps


#4

thank you dincho, it works, happy time~