[solved] Problem generating transactions through the node


#1

To mine aeternity Roma, I’ve generated my wallet address directly through the node. To send the mined AEs, I’m trying to generate a transaction through the node with ./bin/epoch attach

Everything seems to go well. I even get “ok” after the last command : aec_tx_pool:push(SignedTx).

Unfortunately, my AEs never leave my wallet. I wish I could check on the tx, the tx pool or any feedback, but I don’t really know where to start. Any help ? Here are the commands I used :

{_, Sender_pub_key} = aehttp_api_encoder:decode(<<"ak_k1gwWUsYiixD3e6sgVXq8YKae7dLstVLXw9uRTUMpXfkUkJf5">>).
{_, Recipient_pub_key} = aehttp_api_encoder:decode(<<"ak_2Jy6L2DJRiURxrPPPD43e9FW9ni5K9renxB6m2uxyzzutn6nup">>).
Sender_id = aec_id:create(account, Sender_pub_key).
Recipient_id = aec_id:create(account, Recipient_pub_key).
Amount = 2111000000000000000000.
Fee = 20000.
Nonce = 1.                
Payload = <<"">>.
TxData = #{
    sender_id    => Sender_id,
    recipient_id => Recipient_id,
    amount       => Amount,
    fee          => Fee,
    nonce        => Nonce,
    payload      => Payload
}.
PrivKey = crypto:block_decrypt(aes_ecb, crypto:hash(sha256, <<"********">>), EncPriv).
TxBin = aetx:serialize_to_binary(Tx).
TxBinMainnet = << <<"ae_mainnet">>/binary, TxBin/binary>>.
Signature = enacl:sign_detached(TxBinMainnet, PrivKey).
SignedTx = aetx_sign:new(Tx, [Signature]).
aec_tx_pool:push(SignedTx).

#2

Ok, solved. Had a better chance using the link below instead of the official tutorial.