[Solved] Problems installing AEproject

Hey i’ve been struggling to install AEproject for a while. ive been following other threads and none have helped solved my issues. I keep getting errors when i run npm install aeproject.

I tried installing it globally i had errors.
I created an environment with python2.7 and Nodejs version 13.0 but still getting an issue, Something related to an argon library. is Nodejs v9.5.0 a requirement?
I use windows 10. Please help will be appreciated



@Emmanuel Hey, if the issue is with the argon library, I guess that the node version will not help. However, you can try with node version 9.5.0.

Did you check this article?

It will be helpful if you can also share the error.



This is the actual error i get.

C:\WINDOWS\system32\node_modules\argon2>if not defined npm_config_node_gyp (node “C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )
Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
Warning: unrecognized setting VCCLCompilerTool/MultiProcessorCompilation
MSBUILD : error MSB1009: Project file does not exist.
Switch: build/binding.sln
gyp ERR! build error
gyp ERR! stack Error: C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe failed with exit code: 1
gyp ERR! stack at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\build.js:262:23)
gyp ERR! stack at ChildProcess.emit (events.js:198:13)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
gyp ERR! System Windows_NT 10.0.18363
gyp ERR! command “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\WINDOWS\system32\node_modules\argon2
gyp ERR! node -v v10.16.3
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘C:\WINDOWS\system32\package.json’
npm WARN system32 No description
npm WARN system32 No repository field.
npm WARN system32 No README data
npm WARN system32 No license field.

npm ERR! errno 1
npm ERR! [email protected] install: node-gyp-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\ALEX PC\AppData\Roaming\npm-cache_logs\2019-11-29T21_49_02_961Z-debug.log

i tried installing the windows build tools, had no positive effect

Is this an issue with the .NET framework version?

@martingrigorov.chain I’m still waiting for a reply

Hey, @ Emmanuel,

Sorry for the late response on that!
Could you confirm you are using the latest version of AEproject?

In addition as @martingrigorov.chain proposed, it might be better if you are using node version @9.5.0


Hi @Emmanuel
do you have any Visual Studio installed on your machine? if there is/are which version is it?
Did you try these steps Problem installing Forgae/AEproject

1 Like

Yeah i have. Still having the same issues. Ill send screenshots

Ok after installing windows build toos i was successfully able to install. Thanks alot