(solved) Simple contract won't compile!

Hello guys,

I’m starting to build a daepp (actually translating one from solidity to sophia)
but I’m having a lot of problems. Right now I have the following code:

image

The contract compiles without the record lock_contract, but as soon as I add it it wont compile:

Please help since time is of the essence and I have to do the whole thing quickly :frowning:

Also, can someone please tell me how can I debug my code, when I have no highlighting, no adequate error description, nothing…

A better message than just “reason: undefined” would really go a long way for us newbies and would
spare devs the time of dealing with these issues on the forums.

This compiles just fine by my side (in the online IDE):

1 Like

I tested the code in aepp-playground, it compiled, then copy-pasted it to vscode and it worked…

I must’ve messed up the identation somewhere… :sweat:

Anyway, thanks a lot! What online IDE are you using btw?

This is a boosted fork of testnet.contracts.aepps.com that is hosted by @piwo at contracts.aeternity.art. :slight_smile:

2 Likes