[Solved] Unable to send AE from AirGap wallet

Hello and thanks for looking.

I successfully migrated from ERC to Mainnet and hold my AE coins in an AirGap wallet. Wallet and AirGap Vault are installed on the same device.

When attempting to send coins out (to an exchange), I get as far as Vault opening to “Sign transaction”. I get prompted for a password (phone lock code), which I happily provide. Following this, nothing happens. I receive no errors and do not get taken back to the wallet. Everything simply “hangs” with no indication as to what may be wrong. The pass code on the phone has not changed (ever), however, fingerprint has been added to the mix.

I also attempted to re-import the account from seed but Vault is infinitely stuck on “deriving your wallet” message.

Any help will be greatly appreciated. If anyone knows of an alternate wallet that supports seed import, do share


1 Like

Hey @Elated - @andreas can help you here.

Make sure to provide any screenshots if available.


Hi, sorry you are having issues with our wallet.

This looks like an issue with the secure storage. In both the signing and derivation of a new wallet, the seed needs to be read from secure storage, which seems to fail in your case. To me it sounds like the prompt for the fingerprint / pin should be shown, but instead nothing happens and the app is basically waiting for permissions to access the secure storage.

What kind of operating system (including version) / device are you using? As soon as I know that I can dig deeper.

Thank you for the reply Andreas. I’m on Android 10 (security patch update Nov 5, 2019). I do get prompted for the pin/password. It is after I enter it that nothing happens. So, I press “Sign transaction”, get immediately prompted for the password, I enter it, nothing happens at all. Not sure it it’s worth mentioning but during the send process, I sometimes get asked for the finger print and sometimes for the password. Not sure of there is a pattern though it seems random to me. On signing the transaction, however, it is always a password prompt; never the fingerprint.

Thanks again for your time.

Thanks for the response.

I think the password / fingerprint inconsistency is related to a timeout, so if you once use the fingerprint it’s valid for a couple of seconds, so if you immediately try again then it won’t ask again.

That still doesn’t help you though. Could you tell us which device you are using so we can try to reproduce it?

The only thing you could try at this point is completely uninstalling the app and re-installing it. This will wipe your secure storage and you will have to import your secret again. If this is not working, you can download an old APK from github until we fix the issue. Sorry about that.

I’m using the Google Pixel 3 (XL) as my device. I should be able to charge up my old phone and try to recover on there. I’ll do that and update here as to the results.

An update to what’s happening. I installed the AirGap wallet and vault on an older Motorola Nexus 6 (also Google phone running plain android). I was able to restore my account from seed and send the funds out. Of not is that while the processes eventually worked, the send operation had to be repeated about 15 times. Most of the time, I received a message about a ‘property’ being invalid on the wallet while other times, I was taken to the vault after pressing ‘sign transaction’ in the wallet and nothing further would happen. No security prompt or a confirmation screen. Nonetheless, it eventually worked and I am able to access the coins.

Thanks again for your time and support.

1 Like

Hi, sorry for all the trouble you had and I’m glad to hear it worked in the end.

We’ll have to investigate those issues because this obviously shouldn’t happen. We test our apps on both iOS and android and have never received any of the issues you describe. We’ll try to reproduce it by using other devices and software versions.

1 Like