[Solved] Waellet contract call fail address and balance incorrect

Hi guys,
I keep getting “Incorrect address” when trying to make a contract call, and also insufficient balance.
I use windows with both Chrome and Firefox, same error. installed the newest version of Waellet, created an account, logged in into the account. Using testnet.

I tried directly in the developer console as well, calling window.Aepp.request.contractCall(NFT_CONTRACT_SOURCE, NFT_CONTRACT_ADDRESS, ‘transfer_from’ , [publicKey, receiverAeternityAddress, tokenId]);
the variable do have correct values

The address is correct and I do have funds on the account.

Do you have any idea why this is happening and how to get pass it? @milenradkov.chain

Thanks

1 Like

Can you please post this as an issue on gh (https://github.com/waellet/waellet/issues/new), so we can reproduce and fix it. :slight_smile:

1 Like

Done

1 Like

Hey @milenradkov.chain please confirm when this is resolved.

Thank you,
Albena

Hey @albena.chain,

This was resolved here https://github.com/waellet/waellet/pull/296

And will be included in the next release of waellet.

Best,
M

1 Like