SuperheroDex Bug feedback and optimization

SuperheroDex needs to be optimized for mobile.

It works fine on the computer side. But it often gets stuck on the phone.

Add liquidity, TokenA and TokenB often appear opposite, resulting in incorrect addition.

In SWAP, in the TokenA input quantity, tokenB automatically calculates the quantity, usually needs to change a token, such as modifying TokenA, you need to keep the tokenB number unchanged rather than tokenA.

Do you mind sharing your feedback here please: æternity DEX Feedback

1 Like

Can you submit it for you? I can’t open it

1 Like

Hi @LiuShao, just submitted the first issue directly to the corresponding Github repo for you:

The second one I didn’t understand properly, could you please show screenshots to show what you mean?

@LiuShao thanks for sharing your feedback. Regarding adding liquidity: Token A <–> Token B is the same pool as Token B <–> Token A. So unless you specify the wrong amounts everything should work out fine.

Could you provide us with some infos about your mobile device? Which browser, device and operating system are you using and for which tokens do you see the problem?

1 Like

In any device, any browser has an inverted problem. I will give you a screenshot.

In the picture, the numbers in the AE and WTT pools are opposite.

1 Like

@keno.chain

The program error caused the liquidity that cannot be added normally. Like the picture, it makes the proportion wrong. The correct proportion should be 1AE = 280WTT

1 Like

@erik.chain @keno.chain

Like the picture, 280WTT = 1AE. When I change the second column token (AE) is other, such as ABC, then the number of WTT in the first column should be reserved 280, not the number of second columns 1

1 Like

Thanks for the examples. I will take a look and create an issue from it.

2 Likes

The issue is solved. Please try again :slight_smile:

2 Likes

@keno.chain @erik.chain There are still some issues here. I don’t use Github very often, I hope you understand. This afternoon, I used SuperheroDEX to exchange tokens. When I used the MAX button to enter the amount of AE tokens, something strange happened, and DEX stayed in the process of exchange. What makes me even more strange is that my account can’t be transferred normally using Superhero wallet. I checked AE/AENS liquidity exchange and wallet balance and found no problems. What’s wrong? Trouble you check it down.

My AE address:
ak_2pNvAzC6t93NPQrP6xoy8mbBNLEbxcHokvCDbAZEDHUJfrfBbq

AENS coin smart contract address:
ct_reUrrJEvqDMMKRAmeNgMCK1w8WYii4UAJWvtzZEbW5p7ZedBP

This is a normal exchange.




When I use the MAX button to enter the AE amount, an error appears.




Then my wallet is unable to transfer AE.
After clicking Send, the wallet has not responded.

2 Likes

I also encountered a similar situation. I used the superhero wallet to register a just expired aens, and the explorer showed NamePreclaimTx. After that, I exchanged it twice in the superhero dex, and it got stuck, and then my wallet could not transfer money. Now this is The three transactions have been showing pending, it has been 2 days,

1 Like

The two transactions I got stuck on dex are not displayed on explorer, but the transfer records on superhero wallet are displayed, and they are always pending. hope for help thanks

@Cryptocurrency 已经排查出问题。使用SuperheroDex兑换时不能使用“MAX”按钮输入数量,会导致输入量、手续费和余额对不上导致合约无法执行,该笔事务一直在交易池不能完成也无法取消,也就造成无法继续转账。如果很急的话,可以调用智能合约转账,测试过可以成功。最简单的方法就是在Superhero新建一个空地址,发个帖子,再用被限制转账的账户通过Superhero打赏空地址帖子,复制帖子链接,然后在限制账户中认领打赏,很快就会到账。Superhero上空地址可以发贴,应该是用的通用账户的功能,就是官方有个地址在帮你付费发帖,虽然很便宜,但这个功能确实非常适用。

— autotranslate
@Cryptocurrency The problem has been isolated. When redeeming with SuperheroDex, you can’t use the “MAX” button to enter the quantity, which will cause the input, handling fee and balance to not match, resulting in the contract being executed. The transaction has been unable to be completed or cancelled in the trading pool, resulting in the inability to continue the transfer. If it’s urgent, you can call the smart contract transfer, and the test can be successful. The easiest way is to create a new empty address in Superhero, post a post, and then use the restricted account to reward the empty address post through Superhero, copy the post link, and then claim the reward in the restricted account, which will arrive soon. The empty address over Superhero can be posted. It should be the function of a general account, that is, there is an official address to help you pay for posting. Although it is very cheap, this function is indeed very suitable.

1 Like

thanks!!!

I didn’t use the Max button when swapping, I entered the exchange 0.1Ae and it got stuck for the first time, I thought it was a network problem, then I tried again and still exchange 0.1, it got stuck again, and then I register now Anes can’t register either, and it shows “transaction verifovation errors: Nonce 25 is too high valid nonce is 22” when registering

I also encountered the same error.

I created a new account and swap 0.1 on dex is no problem. It could also be a problem when I registered for aens

I found the reason and found a bug. I just tested it again. It was a problem when registering aens. I specially found an aens domain name that just expired a few hours ago. (168168168168.chain) After registering with superhero wallet, my Accounts cannot be transferred, domain names cannot be registered, and rewards cannot be made in superhero. Hope the technicians fix this bug

My first account is still inoperable, but there are not many ae in it, but I hope the team can fix this bug To add, my registration of 168168168168.chain was unsuccessful. After registration, NamePreclaimTx is displayed. Now This domain name can still be registered, but it will be stuck after registration, and then the superhero wallet cannot be operated.