The aepp-cli-js has not been updated

A community developer asked me about CLI just now, and it seems that AEPP-CLI-JS has not been updated to the latest version.

Also: the default library doesn’t seem that friendly? Doesn’t seem to have a new release?

3 Likes

@LiuShao thanks for bringing this up! the updated version has now been released. please tell your friends :wink:

see @aeternity/aepp-cli - npm

2 Likes

In Ubuntu, I tried many times and I still couldn’t create the npm link that the global aecli calls.
I can use /usr/software/nodejs/lib/node_modules/@aeternity/aepp-cli/bin/aecli.js, it works.

[email protected]:/usr/software/nodejs/lib/node_modules/@aeternity/aepp-cli# npm link
npm ERR! Link target resolves to the same directory as link source: /usr/softwar e/nodejs/lib/node_modules/@aeternity/aepp-cli

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2021-06-16T05_26_16_107Z-debug.log