The JS SDK does not support 5.6.3.1

JS SDK supports 5.0.0 < 5.6.3.1> 6.0.0, but does not support 3-digit decimal.

1 Like

Submitted a pull request with fix

Before fixing this on the sdk side I think we should agree on how the node version is encoded now. Isn’t it a SemVer? “5.6.3.1” is not a valid semver version, because:

A normal version number MUST take the form X.Y.Z where X, Y, and Z are non-negative integers, and MUST NOT contain leading zeroes. X is the major version, Y is the minor version, and Z is the patch version. Each element MUST increase numerically. For instance: 1.9.0 -> 1.10.0 -> 1.11.0.

cc: @gorbak25

In 1.0.0-rc2 release of the node was mentioned that it uses semver: https://github.com/aeternity/aeternity/blob/5a8b47201e09c6caf69a47d3b36fb7bc1bfc9d89/docs/release-notes/RELEASE-NOTES-1.0.0-rc2.md#about-this-release

It is semver, 5.6.3.1 was never supposed to be the version of the node, just the tag version of the docker image :slight_smile: But it slipped through…

1 Like

Indeed 5.6.3.1 is invalid semver, the node must follow semver. However, please make sure that the sdk supports semver metadata as well e.g. v5.6.4+7.g123456

1 Like