ToDo Manager Tutorial issues

Hi @piwo, I already have xcode command line tools installed.

I finally managed to make it work with react. ToDoManager.aes still outdated but I finally was able to run it!!!

:slight_smile:

I’ll try later again with vue, but I can work with React anyway. Thanks for your support guys!!!

3 Likes

How did you solve your issues? It may help future community members when they read the post. The contract will be updated.

Hi @ae-omar ,

this seems to me similar to the error I was getting recently while working on React project: https://github.com/facebook/create-react-app/issues/6985 . The error has occurred many times after npm start
On Ubuntu, I was able to solve this with
echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p
https://github.com/gatsbyjs/gatsby/issues/1767
There is no inotify on Mac, it has it’s own tool. Maybe a direction where to look.

Cheers Martin

Actually it worked using by

forgae shape react

Editing both contract definitions and following the rest of the guide to the end.

I’m still unable to make it work with Vue but it’s probably something related to my dev environment as you @piwo and you suggested. I’ll take a look con @martin 's comment anyway.

Bottom line ToDoManager tutorials need to be updated.

3 Likes

thanks for investigation, we know that most tutorials need updating

1 Like

Hey @ae-omar, we have an ongoing bounty for fixing outdated tutorials - see below:

@erik93 can we include this tutorial in the bounty?

1 Like

@MartinG Can you confirm that this tutorial is of sufficient importance to give a bounty for it?

@erik93 it can be, it is a big one with two parts. We should either update it or remove it so the users don’t get confused. IMO if the community is using it is important.

Martin

1 Like

Thanks @ae-albena, I’m aware of it but prefer to focus on finding and filling the gaps on technical side of tutorials.

2 Likes

had the same issue npm install as @ae-omar (on another project but still) on mac. Solved by reverting node to version 10. Inspiration here: https://medium.com/@katopz/how-to-install-specific-nodejs-version-c6e1cec8aa11

1 Like