Waellet connect error

I’m trying to do a contract call via Waellet. While prepping it with
window.Aepp.request.connect();
I get the error
Uncaught (in promise) TypeError: Cannot set property 'resolve' of undefined at inject.js:9

First I tried it in the new Edge where I also had superhero wallet and thought it was a clash between the two wallets (something similar mentioned Two "issues" with wallet connection to different wallets using the aepp-sdk-js). Then I removed superhero and it remains the same. I tried it in Chrome and still getting the same.
Any clue what might be happening?

I tested it in the Firefox canary (win) as well, there I don’t even get an error in the console.
The extension doesn’t exist in the mozilla store anymore @milenradkov.chain maybe you could remove the link from the waellet site since it’s broken.
I used the newest build from github btw, that one is not pushed to chrome plugin store, maybe it would be OK to do it if it’s a stabile build.

1 Like

OK, just to have a conclusion on this.
Since Waellet (and BaseAepp) won’t be the priority, this might end up unresolved or resolved later.

What to do:

  1. Switch to using Superhero wallet
  2. Implement communication using the AEX2, you can find an example here https://github.com/aeternity/aepp-sdk-js/tree/develop/examples/browser/vuejs/connect-two-ae/aepp
    Just bare in mind the example is for connecting two dapps, if you want to communicate only with the ae network, you won’t need half of the code so don’t get confused :slight_smile:
2 Likes

Feel free to also check out our sample AEX-2 implementation: https://github.com/kenodressel/aepp-boilerplate

1 Like