Why local node cannot see the balance


#1

when height is 162 I switch the beneficial address as ‘ak_22rBbBucWeCyjLEjDZfZtaCsQ7AmTCD4FVbJBmPj2A5JHJq7fh’, now the height is 185, there’s no any output when I execute the cmd:

curl http://127.0.0.1:3113/v2/accounts/ak_22rBbBucWeCyjLEjDZfZtaCsQ7AmTCD4FVbJBmPj2A5JHJq7fh

no output, no balance found.

use

curl http://127.0.0.1:3013/accounts/ak_22rBbBucWeCyjLEjDZfZtaCsQ7AmTCD4FVbJBmPj2A5JHJq7fh

and got same result.

aeternity vertion 2.2.0


#2

curl http://127.0.0.1:3013/v2/blocks/top

{“key_block”:{“beneficiary”:“ak_22rBbBucWeCyjLEjDZfZtaCsQ7AmTCD4FVbJBmPj2A5JHJq7fh”,“hash”:“kh_2JhyAW1HF2Dgw3gDoXkwJZrj9dk33TUVp4MUbAjQBe2myL9SYi”,“height”:182,“info”:“cb_Xfbg4g==”,“miner”:“ak_2aPq57xvSMaGo6xXPBZxn3J1HxjSMEHSVj6bVEtNTGEjwih67k”,“nonce”:12497914516055986684,“pow”:[167,507,1095,3373,3386,4193,4949,4973,4982,5043,5611,7058,7455,7560,9228,9368,10786,10917,12150,12460,12686,13532,15689,17731,18100,18238,19593,22241,22733,23557,23652,24158,24257,25125,25607,25877,26095,27747,28635,28864,30816,32551],“prev_hash”:“kh_2PDnUJNeuuhoAgvgzHsu6DwtGsnDhnjCLR2YVrNGpyUKZreLch”,“prev_key_hash”:“kh_2PDnUJNeuuhoAgvgzHsu6DwtGsnDhnjCLR2YVrNGpyUKZreLch”,“state_hash”:“bs_NqcLSomAoEZUW6KiSVi4Xi7z7Hhs98xHqLo9hNWcp4a9BLmMm”,“target”:537193707,“time”:1554622618927,“version”:2}}


#3

Hello, you will have to wait for your node to sync with the network, so your height has to be equal to the one of the rest of the network, check curl https://sdk-mainnet.aepps.com/v2/blocks/top as reference.

You do have ae_mydebug in your config, which makes you run in a private network and not sync with mainnet, so my previous answer didn’t apply.

I am not sure what the problem is, did you restart the node after changing the config?


#4

You have to wait 180 key blocks to get the reward. See https://github.com/aeternity/aeternity/blob/master/apps/aecore/src/aec_governance.erl#L56


#5

He did specify a different beneficiary_reward_delay in his config, so 2 blocks should be correct.


#6

Ah, I missed that. I need more coffee


#7

No output is suspicious, you should get at least {"reason":"Account not found"}. Could you please retry the same curl commands with -v option ?


#8

@goodboy2 what was the solution? Would maybe be helpful for others to know :slight_smile:


#9

It was me who marked it as “solved”, apologies, let’s wait for @goodboy2 to see if it works :wink:


#10

thank you guys, I got the balance now, I found it seems due to the miner not producing the block regularly. Is there a more suitable miner other than mean15-generic for test?