How to start the epoch test net?


#1

Hello,aeternity team!
I install an configure the epoch test net on Ubuntu16.04.3,and this is the epoch.yaml config.

sync:
port: 3115
external_port: 9999

keys:
dir: ./keys
password: “secret”

http:
external:
port: 3003
internal:
port: 3103

websocket:
internal:
port: 3104

mining:
autostart: true

chain:
persist: true
db_path: ./my_db

But it seems not work,and the is no results in the log directory.


#2

我ubuntu 18.04 用二进制文件安装和编译安装都不能正常启动,最后用 docker 的方法成功了,但还是有很多问题。我觉得文档太过于简单了。


#3

我之前运行0.3.5版本时还能同步到测试网络上,现在的版本都没有成功启动过,目前测试网络的使用还是不够友好,不知道主网上线后会不会打包成方便使用的软件,最好能有Windows版本的。你用docker能连接到测试网络的其他节点上吗,还是说在docker自己模拟多个节点


#4

测试网,但怎么查看其他节点我还不会。明天我把输出结果晒出来


#5

Could we please have a good, updated, step-by-step tutorial posted on this forum site on how to do this?

I tried a while back to run a node on an Ubuntu VPS machine since I don’t have a good linux machine at home, but couldn’t setup my .yaml correctly. I was also confused on what to list as my ports in this file because I was using a vps.

I’ve setup and am running several cold-wallet Masternodes, but starting this node for Aeternity has tripped me up.

If we had a good tutorial posted, I think it would encourage a lot of new users, and novices to try it out.

Any help would be greatly appreciated! Super stoked for the upcoming mainet!!! :star_struck:


#6

I second this request!


#7

Hey @AELifer and @rebelnz,

Thank you for your question, your request has been forwarded to our dev team.

We’ll try to prepare a detailed written or video guide and share it in the FAQ section.

We’ll keep you posted.

The AE Team


#8

@aeternity-team Thank you very much!

Am looking forward to it, and will definitely share the guide around when it is ready!!!

:sunglasses:


#9

Will there be a GUI for mining when the mainnet starts for people who are not very computer inclined?


#10

Hi @AELifer and @rebelnz,

Here is the response of our dev team:
You should start from the release notes of the version you run, the latest ones being here:

Each version release notes has important information about new features and BC breaks.
Then, there is a pretty exhaustive documentation on how to install an epoch node from binary here:

How to start an epoch node from source here:

And how to configure an epoch node installed using a release binary:

If there is still something unclear, don’t hesitate to reach out and ask.

Thank you,
The AE Team


#11

Thanks SO much guys! Looks good, will get started right away… :smiley:


#12

You are more than welcome! :slight_smile:


#13

Okay… Trying to get my node mining on the Testnet.

I’m running a 4GB RAM Ubuntu 16.04 on a VPS, and it seems as though I have everything installed correctly.

Some issues i’m having…

  1. After my first attempt to start my node, I get a warning that my ulimit -n is 1024, and that I need to set it to 24576. After I do that, the node seems to start fine.

  2. I run the “curl http://127.0.0.1:3003/v2/top” command to verify that my node is up, and my “connection is refused”.

  3. When I check the log, I am seeing this a lot…

“exec-port with SUID bit set is not allowed to run without setting effective user!”


I’m thinking that my ports are not correct through my firewall and/or my .yaml file?

(On my firewall, i’m only allowing port 124, which is my VPS port, and also port 3003, and in my .yaml file, i’ve only changed the "sync settings to port: 124 & external_port: 124 which is my VPS port as well.)

Any ideas?


#14

The epoch daemon is not allowed to run as privileged user for security reasons. You have to create a non-privileged user and run the node with it.

The details can be found in our troubleshooting wiki page.

I hope that helps, let me know if you have further issues with it.


#15

Thank you, @dincho for the help!

Alright, I created the non-privileged user as instructed.

I started epoch again as the new user… (BTW… I have to set my ulimit every time I restart the node.)

  1. When I do “curl http://31.13.249.70:3013/v2/top” to see if i’m connected to the testnet, it does return a hash, and I do see the height of the blockchain increase every time I enter this command .

  2. As before, when I “curl http://127.0.0.1:3003/v2/top” to see the top of the blockchain as seen by my node, I fail to connect “Connection Refused”, but even when I try to go to this IP from my internet browser, I get the same response.

  3. Now, when I check the logs… The mining log, and epoch_pow_cuckoo logs are both completely empty. The epoch and crash logs do not have any new information at all, nothing from today at all. All I see in the epoch and crash logs, are the old privileged user errors from yesterday. Shouldn’t I see something at least in the epoch log from today?

Still wondering if my port info is correct on my firewall, and in my .yaml file? They are configured as above, in my earlier reply from yesterday. Do I need to allow any additional ports and/or change the “websocket” setting in the .yaml?

If it helps, I did do “bin/epoch check_config epoch.yaml”, and it did check out “OK” by the way.

Also… Just noticed that in /tmp/node, that no “keys” dir was created.

Thanks again for the assistance!


#16

Hey @AELifer,

if you didn’t changed the configuration, the default port is 3013 I see you’re trying to connect to port 3003.

Please try curl http://127.0.0.1:3013/v2/top


#17

you can try this guide


#18

Thanks guys, will give it another try. :blush:


#19

Hi People,
I am trying to set up a node on Ubuntu 16.04 server but have been hitting an error while trying to fetch the epoch from github. See attached a screenshot , below is my sys properties kindly someone tell me if this will work.

Thanks alot for the above conversation it’s been super helpful, cant wait to hit the road on this.

Thanks


#20

It looks to me that your command is incorrect to fetch the release?

I would try all over again from scratch using the guide just above from Chris, step by step. It’s very thorough.

: )