[Solved] Error with https://base.aepps.com

Since the update ,

https://m.facebook.com/story.php?story_fbid=3234209556621168&id=1203540939688050,

the base.aepps.com doesnt connect to the testnet, only connects to the mainnet. Here’s a screenshot of the error

Please any solution to this?
I actually got a link to an aepp https://stage-identity.aepps.com/, which is just like the base.aepp and this connects to the testnet fine, but the base.aepps doesn’t

@Steviekusu

2 Likes

@martingrigorov.chain pls can you help with this? The error was after they trying connecting a Daepp after the upgrade today

Hey guys, it is probably something related to the hard fork yesterday. After such an update there is some downtime needed for the apss to release new version. Probably this is the case here, I can’t tell.

@stoyan.chain is the right person here.

Best,
Martin

1 Like

Hey,

Try it again now at base.aepps.com

Make sure the version is 0.12.0 in the Settings view. If it is not, refresh and you will get an in-app notification to Update.

Thanks,
St

1 Like

Ok thanks a lot! @stoyan.chain :boom:

1 Like

You are welcome! @Emmanuel

@stoyan.chain when running my dapp on the base.aepps , i still get the iCompiler 3.2.0 support only consensus protocol less then 3(Fortuna) error, please help

Have a look at this thread:

I’ve checked the thread but this solution doesnt apply to my problem, when i run my dapp on the base.aepps i still get the fortuna error and decodedGet returns undefined, so i cant display what i stored on the blockchain

@Goodness
@Steviekusu
@stoyan.chain

having an issue, we need a fix asap

Try it again now. We made a new release today.

contractCall not working in baseapps @stoyan.chain

@Goodness can you provide a screenshot?

its getting this error While calling getAccountByPubkey (pubkey),

i highlighted the error
thanks

Thank you. We will have a look tomorrow.

In the mean time… the version of the SDK inside a particular production version of the Base aepp (always check in Settings) is clear in the release notes: https://github.com/aeternity/aepp-base/releases

so its working now @stoyan.chain
but on the window os
on ubuntu 18.04 i get all manner of errors
aepp-sdk.browser-script.js:31 Uncaught TypeError: Cannot read property ‘resolve’ of undefined
at c (aepp-sdk.browser-script.js:31)

While calling getAccountByPubkey (pubkey), GET to https://sdk-testnet.aepps.com/v2/accounts/ak_2Wzo6RBp3XCkxCbsXn5XFhkyCkXLMn5HThkFAwgXvPZPGJh7ff failed with 404: Account not found
so i can’t write to the blockchain on ubuntu but it works on windows

@noandrea is this something you can respond to or someone responsible for the nodes should address it?