Aeternity Governance Aepp Public Testing

Hello all,

as introduced a few weeks back we started work on the governance aepp to implement a polling system via smart contract as described here: Governance Polling System Aepp Introduction

Now we are ready to have a public testing session for our aepp prototype. It’s all open source and you can inspect it at https://github.com/aeternity/aepp-governance.

Join the public testing

  • open your base-aepp (version >= 0.9.0) and select testnet in the network settings
  • open governance.aeternity.com in the aepps tab of base-aepp
  • try it out

Known problems

  • detailed information about polls may not load, we have to do more work on caching to optimize the experience here
  • maybe open polls may result in a confusing UI, we will provide a better sorting and filtering here
  • external links won’t open
  • minor design issues are still to be fixed

Please let us know in this thread about all issues or any other feedback or questions!

Thank you

5 Likes

Great!! First feedback, can the app directly deep link into the base aepp if I have it installed?

1 Like

I get an endless loop here:

When submitting a poll

1 Like

We can have a look if deep linking is possible to implement. About the infinite spinning, did you get two requests to sign transactions?

Can you try again, maybe this was just a network issue with your base-aepp, to the testnet nodes.

Same issue with spinning. Didnt ask me to verify transaction yet. Happens right after i click “create poll”. Mobile app ioS

Does not work for me neither. IOS/testnet

@Luka @dincho do you have balance and set testnet? Also are you using the iOS base aepp natively or as PWA (version >= 0.9.0)?

@emin @Luka @dincho does voting work for you?

Yes, testnet and I have balance, native base app last version from app store. Voting could not try, it doesnt find any polls

Same as Luca (20 chars post padding?!?!?)

@dincho @Luka, is your base-aepp version >= 0.9.0? Otherwise the aepp cant work.

Official AppStore version is 0.8.11

Yes, that’s the issue. As written in the initial post version 0.9.0 or greater is required. Version 0.8.11 shipped with a sdk that included a bug and earlier versions are incompatible with the sdk the aepp uses.

Tried, it works on 0.9.0

2 Likes

Version 0.11.0 of the Base aepp will most likely support deep-linking.

We are preparing 0.10.0 for release in PWA tomorrow. Android will follow shortly after.

I am not sure when we will release 0.11.0 but we can make sure it’s before ae universe.

Re: iOS version: we are currently held back by the iOS App Store review on releasing version 0.9.0. We are working with them to resolve the concerns the reviewers have. I will post here when we have released a version newer than 0.8.11 in iOS.

I tested the governance aepp. It worked well for me!

Comments:

  1. We really need an aepp icon… :slight_smile:

  2. There was a slight lag after authorizing my account, when I was not sure if the aepp will ever load. It did eventually. So I succeeded. But if the lag/wait time was significant enough I would have assumed it will not work and left.

  3. The loading indicator was over the message saying I should switch to the Testnet. I read the message anyway… but somebody else might not.

  4. I think it’s a bit tricky to ask the user to input block height for the closing without them having any context for when a certain block height would take place without entering it. To resolve this “chicken or the egg (which comes first)” puzzle, I recommend a few placeholder values are added for selection… which correspond to say 1 week, 1 month, 1 year… so that the user has something to relate to… once they select one of the placeholder values they will see the calculation of the estimate below the input field (and could more easily navigate things from there).

  5. I was slightly lost in the UI at first. Because there are quite a few elements. The bottom row of icons was harder for me to interpret than the top menu items. Since we are in the testing phase this works. But it’s also a good idea to do some user tests on alternative UI/UX options… to get to a more elegant solution.

That’s it for now. Thanks for making this happen!

3 Likes

Hey @stoyan_ae,

as always we highly appreciate your keen eye for UX when testing our aepp.

  1. 100% agreed, we are working with our designer. This is our current draft (feedback appreciated):

  2. Do you notice this behavior every time you open the aepp? During the first load we do a rather extensive wallet search to offer you a choice if we detect more than one wallet. This is why it might take some time initially.

  3. Good catch! We will address this.

  4. I will experiment a little with this. It is rather tricky as we do not want to suggest we could predict the time a block height is reached but we know its basically impossible to estimate a date in block height without technical knowledge. What would you think if we prefill the input with a block height roughly a month or two in the future which would also provide the user with an idea on how long a poll should be open?

  5. Yes I agree. We still have the problem that we don’t want to double up on the base aepps top navigation which is why we opted for the bottom approach. We will continue to gather user feedback on this topic and might update the ui if we see the need for it.

2 Likes

I get this when trying to create the poll

Now, the account I used has a zero balance, so maybe that’s the problem?

I use Chrome browser, viewing it as iPhone 8 Plus

Yes, without balance the transaction fee for creating a poll or participating in votes can not be covered, nonetheless we should improve the error message. Thank you for the feedback

3 Likes